aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake/0002-cmake-Prevent-the-detection-of-Qt5.patch
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2019-02-12 17:19:49 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-14 11:20:06 +0000
commitf40a5da14ec688f751d6394ce9a997578904fd8d (patch)
tree772680d79963d90aa888fb7c5933eef8e7d89875 /meta/recipes-devtools/cmake/cmake/0002-cmake-Prevent-the-detection-of-Qt5.patch
parentd52d1d92618bfda6f4206eb81e6d81c431d45227 (diff)
downloadopenembedded-core-contrib-f40a5da14ec688f751d6394ce9a997578904fd8d.tar.gz
cmake: update to 3.13.4
All patches have been rebased on top of the 3.13.4 release. I successfully built all CMake recipes in oe-core and meta-oe. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Cc: Otavio Salvador <otavio.salvador@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake/0002-cmake-Prevent-the-detection-of-Qt5.patch')
-rw-r--r--meta/recipes-devtools/cmake/cmake/0002-cmake-Prevent-the-detection-of-Qt5.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/cmake/cmake/0002-cmake-Prevent-the-detection-of-Qt5.patch b/meta/recipes-devtools/cmake/cmake/0002-cmake-Prevent-the-detection-of-Qt5.patch
index 6f788ada00..3bea6935b7 100644
--- a/meta/recipes-devtools/cmake/cmake/0002-cmake-Prevent-the-detection-of-Qt5.patch
+++ b/meta/recipes-devtools/cmake/cmake/0002-cmake-Prevent-the-detection-of-Qt5.patch
@@ -39,7 +39,7 @@ diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index b8b724ed8..63f6bb6d2 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
-@@ -1322,7 +1322,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
+@@ -1297,7 +1297,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
set(CMake_TEST_Qt5 1)
endif()
if(CMake_TEST_Qt5)
@@ -70,10 +70,10 @@ diff --git a/Tests/QtAutogen/AutogenTest.cmake b/Tests/QtAutogen/AutogenTest.cma
index 8c0a14fca..e9923b21a 100644
--- a/Tests/QtAutogen/AutogenTest.cmake
+++ b/Tests/QtAutogen/AutogenTest.cmake
-@@ -22,7 +22,7 @@ if (QT_TEST_VERSION STREQUAL 4)
+@@ -22,7 +22,7 @@ if (QT_TEST_VERSION EQUAL 4)
endmacro()
- elseif(QT_TEST_VERSION STREQUAL 5)
+ elseif(QT_TEST_VERSION EQUAL 5)
- find_package(Qt5Widgets REQUIRED)
+ #find_package(Qt5Widgets REQUIRED)
@@ -96,7 +96,7 @@ diff --git a/Tests/RunCMake/CMakeLists.txt b/Tests/RunCMake/CMakeLists.txt
index 637c5c2cb..c0376effc 100644
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
-@@ -291,7 +291,7 @@ add_RunCMake_test(configure_file)
+@@ -310,7 +310,7 @@ add_RunCMake_test(configure_file)
add_RunCMake_test(CTestTimeoutAfterMatch)
find_package(Qt4 QUIET)