summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.0.bb
diff options
context:
space:
mode:
authorhongxu <hongxu.jia@windriver.com>2021-08-04 21:08:35 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2021-08-09 10:19:38 +0800
commitd99b4dac74add826aa63ecb20c427d2884985329 (patch)
tree18f58db480a80c71cceff7140ffdac5a0c656d2a /meta/recipes-devtools/createrepo-c/createrepo-c_0.17.0.bb
parentb415b0bc39dfae329e845569a122bcd301c326cc (diff)
downloadopenembedded-core-contrib-d99b4dac74add826aa63ecb20c427d2884985329.tar.gz
createrepo-c: fix createrepo-c failed in nativesdk
In sdk, call createrepo-c failed with: ... $ createrepo_c --update ./test_repo/rpm Directory walk started Critical: Failed to detect compression for file ./test_repo/rpm/cortexa72/hello-2.10-r0.cortexa72.rpm: magic_load() failed: could not find any valid magic files! ... Since commit [ea666fbc74 createrepo-c: set path to magic database for native and nativesdk] applied, the MAGIC is incorrectly assigned. The variable datadir will be expanded automatically for nativesdk, do not need to add prefix ${SDKPATHNATIVE} to MAGIC Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 54368f1b02e1ac4aa068515730a8c8bcd3683eb3) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'meta/recipes-devtools/createrepo-c/createrepo-c_0.17.0.bb')
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c_0.17.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.0.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.0.bb
index e0433806b2..7480affbc0 100644
--- a/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.0.bb
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.0.bb
@@ -33,8 +33,8 @@ do_install_append_class-native() {
do_install_append_class-nativesdk() {
create_wrapper ${D}/${bindir}/createrepo_c \
RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
- MAGIC=${SDKPATHNATIVE}${datadir}/misc/magic.mgc
+ MAGIC=${datadir}/misc/magic.mgc
create_wrapper ${D}/${bindir}/modifyrepo_c \
- MAGIC=${SDKPATHNATIVE}${datadir}/misc/magic.mgc
+ MAGIC=${datadir}/misc/magic.mgc
rm -rf ${D}/etc
}