summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file
diff options
context:
space:
mode:
authorOleksandr Hnatiuk <ohnatiuk@cisco.com>2023-07-25 09:51:48 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-07-27 21:07:18 +0100
commitc6206249683876670602888e78ecaf719753a317 (patch)
tree7312218ca8fcaf8651a5fd3324e2b541890bda74 /meta/recipes-devtools/file
parent4c95a7381ea835dce8119845d6c146800e98f960 (diff)
downloadopenembedded-core-contrib-c6206249683876670602888e78ecaf719753a317.tar.gz
file: fix the way path is written to environment-setup.d
$OECORE_NATIVE_SYSROOT is not escaped, thus it is expanded to an empty string. This happens to work because we have ${datadir} which in this context is relocated to the buildtools sysroot after installation of buildtools. If the $ before OECORE_NATIVE_SYSROOT is escaped, it will be saved to file.sh as intended, but MAGIC will point to the wrong location because both OECORE_NATIVE_SYSROOT and datadir resolve to sysroot which doubles the path like so: /path/to/buildtools/sysroots/x86_64-xesdk-linux/path/to/buildtools/sysroots/x86_64-xesdk-linux/usr/share/misc/magic.mgc which does not exist. So, removing reference to OECORE_NATIVE_SYSROOT. Signed-off-by: Oleksandr Hnatiuk <ohnatiuk@cisco.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-devtools/file')
-rw-r--r--meta/recipes-devtools/file/file_5.44.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/file/file_5.44.bb b/meta/recipes-devtools/file/file_5.44.bb
index 0834384230..3ce266475b 100644
--- a/meta/recipes-devtools/file/file_5.44.bb
+++ b/meta/recipes-devtools/file/file_5.44.bb
@@ -48,7 +48,7 @@ do_install:append:class-nativesdk() {
create_wrapper ${D}/${bindir}/file MAGIC=${datadir}/misc/magic.mgc
mkdir -p ${D}${SDKPATHNATIVE}/environment-setup.d
cat <<- EOF > ${D}${SDKPATHNATIVE}/environment-setup.d/file.sh
- export MAGIC="$OECORE_NATIVE_SYSROOT${datadir}/misc/magic.mgc"
+ export MAGIC="${datadir}/misc/magic.mgc"
EOF
}