summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/flex/flex
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-15 13:59:34 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-22 16:08:44 +0000
commit4fe048b7b32eb3d20a43171b83e8ad2037192d34 (patch)
tree45aeb9ffd276685069f18150e5854cadf9c7c38e /meta/recipes-devtools/flex/flex
parent51265ca2b77c05c94f65d3bc8e1883853b0b540c (diff)
downloadopenembedded-core-contrib-4fe048b7b32eb3d20a43171b83e8ad2037192d34.tar.gz
flex: update to 2.6.0
Drop backported 0001-bison-test-fixes-Do-not-use-obsolete-bison-construct.patch Test cases have been completely rearranged upstream, so ptest support is fully rewritten. Merge split bb/inc as there's no other user of the .inc [RB] As automake insists adding BUILD_SOURCES as a dependency to the "all" target, remove tests/ from the build unless ptests are enabled. This means native builds don't need a bison dependency. If ptests are enabled, we build-depend on flex-native and bison-native for the test suite, and tell it to use the flex-native binary instead of attempting to run the cross flex it just built. [RB] Move in-tree files from files/ to flex/ for consistency. [RB] Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/flex/flex')
-rw-r--r--meta/recipes-devtools/flex/flex/0001-tests-add-a-target-for-building-tests-without-runnin.patch28
-rw-r--r--meta/recipes-devtools/flex/flex/disable-tests.patch19
-rw-r--r--meta/recipes-devtools/flex/flex/do_not_create_pdf_doc.patch17
-rwxr-xr-xmeta/recipes-devtools/flex/flex/run-ptest5
4 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-devtools/flex/flex/0001-tests-add-a-target-for-building-tests-without-runnin.patch b/meta/recipes-devtools/flex/flex/0001-tests-add-a-target-for-building-tests-without-runnin.patch
new file mode 100644
index 0000000000..556c240b24
--- /dev/null
+++ b/meta/recipes-devtools/flex/flex/0001-tests-add-a-target-for-building-tests-without-runnin.patch
@@ -0,0 +1,28 @@
+From b4aa18d939fc0c8825fa584dfcee1a7da61099cf Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Thu, 10 Dec 2015 16:09:26 +0200
+Subject: [PATCH] tests: add a target for building tests without running them
+
+Upstream-Status: Inappropriate [oe specific]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ tests/Makefile.am | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 4ac3c17..0025cfe 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -21,6 +21,9 @@
+
+ TESTS = $(check_PROGRAMS) options.cn
+
++# This allows building tests without running them
++buildtests: $(TESTS)
++
+ # The script testwrapper.sh will run most tests as is. A couple tests
+ # in the suite end in .reject, .table and the like so that we can pass
+ # different arguments to the test runner. We list those extensions so
+--
+2.6.2
+
diff --git a/meta/recipes-devtools/flex/flex/disable-tests.patch b/meta/recipes-devtools/flex/flex/disable-tests.patch
new file mode 100644
index 0000000000..4dc801d72c
--- /dev/null
+++ b/meta/recipes-devtools/flex/flex/disable-tests.patch
@@ -0,0 +1,19 @@
+Due to automake stupidity the Makefile in tests/ has an 'all' target that
+depends on $(BUILD_SOURCES), which means when building flex parts of the test
+suite are built even if they're not needed, resulting in flex needing
+flex-native and bison-native to build.
+
+This patch removes the tests directory from SUBDIRS and will be conditionally
+applied by the recipe.
+
+Upstream-Status: Inappropriate
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/Makefile.am b/Makefile.am
+index 076ccad..0574d7b 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -55,3 +55,2 @@ SUBDIRS = \
+ po \
+- tests \
+ tools
diff --git a/meta/recipes-devtools/flex/flex/do_not_create_pdf_doc.patch b/meta/recipes-devtools/flex/flex/do_not_create_pdf_doc.patch
new file mode 100644
index 0000000000..032833ae7a
--- /dev/null
+++ b/meta/recipes-devtools/flex/flex/do_not_create_pdf_doc.patch
@@ -0,0 +1,17 @@
+Upstream-Status: Inappropriate (embedded specific)
+
+Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
+
+Index: flex-2.5.37/doc/Makefile.am
+===================================================================
+--- flex-2.5.37.orig/doc/Makefile.am 2012-07-21 04:18:27.000000000 +0300
++++ flex-2.5.37/doc/Makefile.am 2013-07-30 17:57:09.834834531 +0300
+@@ -2,7 +2,7 @@
+
+ info_TEXINFOS = flex.texi
+ dist_man_MANS = flex.1
+-dist_doc_DATA= flex.pdf
++EXTRA_DIST= flex.pdf
+
+ CLEANFILES = \
+ flex.hks \
diff --git a/meta/recipes-devtools/flex/flex/run-ptest b/meta/recipes-devtools/flex/flex/run-ptest
new file mode 100755
index 0000000000..19db337900
--- /dev/null
+++ b/meta/recipes-devtools/flex/flex/run-ptest
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+# make would want to rebuild some files with a compiler otherwise :-/
+make FLEX=/usr/bin/flex -t check-TESTS || true
+make FLEX=/usr/bin/flex check-TESTS