summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-22 09:36:03 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-22 18:30:06 +0100
commit17ba68f9ae09ae20eb11dfb03bcaa99428b74bf6 (patch)
treeb79380ed8d3da3ce8200ce0a44aecbdda1999e85 /meta/recipes-devtools/gcc
parent7a9202d0478f0021b0ecd03b8d4af8d56c8e3265 (diff)
downloadopenembedded-core-contrib-17ba68f9ae09ae20eb11dfb03bcaa99428b74bf6.tar.gz
gcc-runtime: Fold common configuration into gcc-configure-runtime.inc
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc')
-rw-r--r--meta/recipes-devtools/gcc/gcc-configure-runtime.inc5
-rw-r--r--meta/recipes-devtools/gcc/gcc-runtime_4.7.bb4
-rw-r--r--meta/recipes-devtools/gcc/gcc-runtime_4.8.bb4
3 files changed, 5 insertions, 8 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-configure-runtime.inc b/meta/recipes-devtools/gcc/gcc-configure-runtime.inc
index f89ca6bbad..2ff8561e0d 100644
--- a/meta/recipes-devtools/gcc/gcc-configure-runtime.inc
+++ b/meta/recipes-devtools/gcc/gcc-configure-runtime.inc
@@ -7,6 +7,11 @@ EXTRA_OECONF_PATHS = " \
--with-sysroot=${STAGING_DIR_TARGET} \
--with-build-sysroot=${STAGING_DIR_TARGET}"
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
+
+EXTRA_OECONF += "--disable-libunwind-exceptions"
+EXTRA_OECONF_append_linuxstdbase = " --enable-clocale=gnu"
+
RUNTIMETARGET = "libssp libstdc++-v3 libgomp"
# ?
# libiberty
diff --git a/meta/recipes-devtools/gcc/gcc-runtime_4.7.bb b/meta/recipes-devtools/gcc/gcc-runtime_4.7.bb
index fbaf057fed..c16d27eecd 100644
--- a/meta/recipes-devtools/gcc/gcc-runtime_4.7.bb
+++ b/meta/recipes-devtools/gcc/gcc-runtime_4.7.bb
@@ -2,7 +2,3 @@ require recipes-devtools/gcc/gcc-${PV}.inc
require gcc-configure-runtime.inc
require gcc-package-runtime.inc
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
-
-EXTRA_OECONF += "--disable-libunwind-exceptions"
-EXTRA_OECONF_append_linuxstdbase = " --enable-clocale=gnu"
diff --git a/meta/recipes-devtools/gcc/gcc-runtime_4.8.bb b/meta/recipes-devtools/gcc/gcc-runtime_4.8.bb
index fbaf057fed..c16d27eecd 100644
--- a/meta/recipes-devtools/gcc/gcc-runtime_4.8.bb
+++ b/meta/recipes-devtools/gcc/gcc-runtime_4.8.bb
@@ -2,7 +2,3 @@ require recipes-devtools/gcc/gcc-${PV}.inc
require gcc-configure-runtime.inc
require gcc-package-runtime.inc
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
-
-EXTRA_OECONF += "--disable-libunwind-exceptions"
-EXTRA_OECONF_append_linuxstdbase = " --enable-clocale=gnu"