summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-binary-native_1.17.5.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-12-15 23:40:24 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-12-17 09:56:09 +0000
commit00da24376f4214f30d3eb775d990080b49bb5d3c (patch)
tree2ade8b15f79b6c5bb6c9762ebd793aa6fb0e27d6 /meta/recipes-devtools/go/go-binary-native_1.17.5.bb
parentd311ee2e879a804df05f7283568c840e7dd2230c (diff)
downloadopenembedded-core-contrib-00da24376f4214f30d3eb775d990080b49bb5d3c.tar.gz
go: upgrade 1.17.4 -> 1.17.5
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go-binary-native_1.17.5.bb')
-rw-r--r--meta/recipes-devtools/go/go-binary-native_1.17.5.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-binary-native_1.17.5.bb b/meta/recipes-devtools/go/go-binary-native_1.17.5.bb
new file mode 100644
index 0000000000..f07d299b40
--- /dev/null
+++ b/meta/recipes-devtools/go/go-binary-native_1.17.5.bb
@@ -0,0 +1,46 @@
+# This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org.
+
+SUMMARY = "Go programming language compiler (upstream binary for bootstrap)"
+HOMEPAGE = " http://golang.org/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707"
+
+PROVIDES = "go-native"
+
+SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}"
+SRC_URI[go_linux_amd64.sha256sum] = "bd78114b0d441b029c8fe0341f4910370925a4d270a6a590668840675b0c653e"
+SRC_URI[go_linux_arm64.sha256sum] = "6f95ce3da40d9ce1355e48f31f4eb6508382415ca4d7413b1e7a3314e6430e7e"
+
+UPSTREAM_CHECK_URI = "https://golang.org/dl/"
+UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux"
+
+S = "${WORKDIR}/go"
+
+inherit goarch native
+
+do_compile() {
+ :
+}
+
+make_wrapper() {
+ rm -f ${D}${bindir}/$1
+ cat <<END >${D}${bindir}/$1
+#!/bin/bash
+here=\`dirname \$0\`
+export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}"
+\$here/../lib/go/bin/$1 "\$@"
+END
+ chmod +x ${D}${bindir}/$1
+}
+
+do_install() {
+ find ${S} -depth -type d -name testdata -exec rm -rf {} +
+
+ install -d ${D}${bindir} ${D}${libdir}/go
+ cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/
+
+ for f in ${S}/bin/*
+ do
+ make_wrapper `basename $f`
+ done
+}