summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-02-23 20:13:19 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-26 15:16:56 +0000
commit8e078238312948e8c7b09c66ba7a186512e995d3 (patch)
tree75c0935c06e27ed5b36f8c1a7289f5144f51d598 /meta/recipes-devtools/go
parent5c41c6ed4e2e70d18b32c460b8c8e1aadd54584f (diff)
downloadopenembedded-core-contrib-8e078238312948e8c7b09c66ba7a186512e995d3.tar.gz
go: Enable CGO and pie buildmode on rv64
go1.16 has added CGO support for riscv64 arch Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go')
-rw-r--r--meta/recipes-devtools/go/go-runtime_1.16.bb1
-rw-r--r--meta/recipes-devtools/go/go_1.16.bb5
2 files changed, 2 insertions, 4 deletions
diff --git a/meta/recipes-devtools/go/go-runtime_1.16.bb b/meta/recipes-devtools/go/go-runtime_1.16.bb
index d6ddb31ed4..63464a1501 100644
--- a/meta/recipes-devtools/go/go-runtime_1.16.bb
+++ b/meta/recipes-devtools/go/go-runtime_1.16.bb
@@ -1,4 +1,3 @@
-export CGO_ENABLED_riscv64 = ""
require go-${PV}.inc
require go-runtime.inc
diff --git a/meta/recipes-devtools/go/go_1.16.bb b/meta/recipes-devtools/go/go_1.16.bb
index d4812c0f0a..4e9e0ebec8 100644
--- a/meta/recipes-devtools/go/go_1.16.bb
+++ b/meta/recipes-devtools/go/go_1.16.bb
@@ -4,15 +4,14 @@ require go-target.inc
inherit linuxloader
export GOBUILDMODE=""
-export CGO_ENABLED_riscv64 = ""
export GO_LDSO = "${@get_linuxloader(d)}"
export CC_FOR_TARGET = "gcc"
export CXX_FOR_TARGET = "g++"
-# mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv and its
+# mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv32 and its
# variants.
python() {
- if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv' in d.getVar('TARGET_ARCH',True):
+ if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv32' in d.getVar('TARGET_ARCH',True):
d.appendVar('INSANE_SKIP_%s' % d.getVar('PN',True), " textrel")
}