summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/json-c/json-c_0.13.1.bb
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-05-02 14:37:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-09 11:22:34 +0100
commitbb9a62acaf9aa1691ce276bf037ba35b6c924276 (patch)
treed35dc273f5527c4a7554a7a54f52dacf79af390e /meta/recipes-devtools/json-c/json-c_0.13.1.bb
parent9f568afee706d689838a00579e6252f778796612 (diff)
downloadopenembedded-core-contrib-bb9a62acaf9aa1691ce276bf037ba35b6c924276.tar.gz
json-c: upgrade to 0.13.1
* from https://github.com/json-c/json-c/commit/861c1a82868831bf82222f974f05c2af5a975d12 * Bump the major version of the .so library generated up to 4.0 to avoid conflicts because some downstream packagers of json-c had already done their own bump to ".so.3" for a much older 0.12 release. * Add const size_t json_c_object_sizeof() * Avoid invalid free (and thus a segfault) when ref_count gets < 0 * PR#394: fix handling of custom double formats that include a ".0" * Avoid uninitialized variable warnings in json_object_object_foreach * Issue #396: fix build for certain uClibc based systems. * Add a top level fuzz directory for fuzzers run by OSS-Fuzz Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/json-c/json-c_0.13.1.bb')
-rw-r--r--meta/recipes-devtools/json-c/json-c_0.13.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/json-c/json-c_0.13.1.bb b/meta/recipes-devtools/json-c/json-c_0.13.1.bb
new file mode 100644
index 0000000000..5b10e68297
--- /dev/null
+++ b/meta/recipes-devtools/json-c/json-c_0.13.1.bb
@@ -0,0 +1,30 @@
+SUMMARY = "C bindings for apps which will manipulate JSON data"
+DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
+HOMEPAGE = "https://github.com/json-c/json-c/wiki"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
+
+SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz"
+SRC_URI[md5sum] = "04969ad59cc37bddd83741a08b98f350"
+SRC_URI[sha256sum] = "b87e608d4d3f7bfdd36ef78d56d53c74e66ab278d318b71e6002a369d36f4873"
+
+UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+).tar"
+# json-c releases page is fetching the list of releases in some weird XML format
+# from https://s3.amazonaws.com/json-c_releases and processes it with javascript :-/
+#UPSTREAM_CHECK_URI = "https://s3.amazonaws.com/json-c_releases/releases/index.html"
+RECIPE_UPSTREAM_VERSION = "0.13.1"
+RECIPE_UPSTREAM_DATE = "Mar 04, 2018"
+CHECK_DATE = "May 02, 2018"
+
+RPROVIDES_${PN} = "libjson"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-rdrand"
+
+do_configure_prepend() {
+ # Clean up autoconf cruft that should not be in the tarball
+ rm -f ${S}/config.status
+}
+
+BBCLASSEXTEND = "native nativesdk"