summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-04-07 19:00:14 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-04-19 14:14:01 +0100
commitee06fc2a19665461e143fe3bf7e94b703652e1cf (patch)
tree2c7f5699dbd9af26d0d6b7acfea347473861c5d2 /meta/recipes-devtools/llvm
parent5cbf04ee8202ad9d90b1e1e527203f34e921916b (diff)
downloadopenembedded-core-contrib-ee06fc2a19665461e143fe3bf7e94b703652e1cf.tar.gz
llvm: update 13.0.1 -> 14.0.0
llvm-config no longer links with libLLVM, so there is no need to install it in -native (and it isn't built in the first place). This also significantly speeds up llvm-native build. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/llvm')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 9400bf0821..13f7fb763e 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -19,7 +19,7 @@ inherit cmake pkgconfig
PROVIDES += "llvm${PV}"
-PV = "13.0.1"
+PV = "14.0.0"
MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
@@ -27,7 +27,7 @@ LLVM_RELEASE = "${PV}"
LLVM_DIR = "llvm${LLVM_RELEASE}"
BRANCH = "release/${MAJOR_VERSION}.x"
-SRCREV = "75e33f71c2dae584b13a7d1186ae0a038ba98838"
+SRCREV = "329fda39c507e8740978d10458451dcdb21563be"
SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \
file://0006-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch;striplevel=2 \
file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
@@ -145,7 +145,6 @@ do_install() {
do_install:class-native() {
install -D -m 0755 ${B}/bin/llvm-tblgen ${D}${bindir}/llvm-tblgen${PV}
install -D -m 0755 ${B}/bin/llvm-config ${D}${bindir}/llvm-config${PV}
- install -D -m 0755 ${B}/lib/libLLVM-${MAJOR_VERSION}.so ${D}${libdir}/libLLVM-${MAJOR_VERSION}.so
}
PACKAGES =+ "${PN}-bugpointpasses ${PN}-llvmhello ${PN}-libllvm ${PN}-liboptremarks ${PN}-liblto"