aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg_0.1.8.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-01-20 11:05:16 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-24 11:54:20 +0000
commit930424bf2f5593256dcacac6e7cf98699fc2a0db (patch)
tree143397dca6c2a486335c5f1c24f0eb6821c873ef /meta/recipes-devtools/opkg/opkg_0.1.8.bb
parentc6c3f8745090c00eb02614a003925c533660e813 (diff)
downloadopenembedded-core-contrib-930424bf2f5593256dcacac6e7cf98699fc2a0db.tar.gz
opkg: move common code & metadata into opkg.inc to reduce code duplication
(From OE-Core rev: da70cc9f33845d62943afc78168e56931d0a9b15) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_0.1.8.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.1.8.bb44
1 files changed, 2 insertions, 42 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.1.8.bb b/meta/recipes-devtools/opkg/opkg_0.1.8.bb
index 18cf0428ce..c206b3782f 100644
--- a/meta/recipes-devtools/opkg/opkg_0.1.8.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.1.8.bb
@@ -1,48 +1,8 @@
require opkg.inc
-PROVIDES += "virtual/update-alternatives"
-RPROVIDES_update-alternatives-cworth += "update-alternatives"
-RCONFLICTS_update-alternatives-cworth = "update-alternatives-dpkg"
-RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-config-base"
-RDEPENDS_${PN}_virtclass-native = ""
-RDEPENDS_${PN}_virtclass-nativesdk = ""
-PACKAGE_ARCH_update-alternatives-cworth = "all"
-
SRC_URI = "http://opkg.googlecode.com/files/opkg-${PV}.tar.gz \
file://add_vercmp.patch \
file://headerfix.patch \
-"
-
-PR = "r4"
-
-PACKAGES =+ "libopkg${PKGSUFFIX}-dev libopkg${PKGSUFFIX} update-alternatives-cworth${PKGSUFFIX}"
-
-FILES_update-alternatives-cworth${PKGSUFFIX} = "${bindir}/update-alternatives"
-FILES_libopkg${PKGSUFFIX}-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
-FILES_libopkg${PKGSUFFIX} = "${libdir}/*.so.* ${localstatedir}/lib/opkg/"
-
-# We need to create the lock directory
-do_install_append() {
- install -d ${D}${localstatedir}/lib/opkg
-}
-
-pkg_postinst_${PN} () {
-#!/bin/sh
-if [ "x$D" != "x" ]; then
- install -d ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d
- # this happens at S98 where our good 'ole packages script used to run
- echo "#!/bin/sh
-opkg-cl configure
-rm -f /${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
-" > $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
- chmod 0755 $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
-fi
-
-update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
-}
-
-pkg_postrm_${PN} () {
-#!/bin/sh
-update-alternatives --remove opkg ${bindir}/opkg-cl
-}
+ "
+PR = "${INC_PR}.0"