summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/patch
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-05-22 02:14:23 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-30 20:45:48 +0100
commitdd219cb2608e5800dcd900117b37ad8cf9ac689a (patch)
tree60458670784b3ffbe5c91d50f08d41d8e1995650 /meta/recipes-devtools/patch
parente7379a75ea2698d149ab2e7147f1140132ebfedf (diff)
downloadopenembedded-core-contrib-dd219cb2608e5800dcd900117b37ad8cf9ac689a.tar.gz
patch: use PACKAGECONFIG to ensure correct dependency for xattr
This will enable or disable xattr with the correct dependency on attr as needed. Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/patch')
-rw-r--r--meta/recipes-devtools/patch/patch_2.7.1.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-devtools/patch/patch_2.7.1.bb b/meta/recipes-devtools/patch/patch_2.7.1.bb
index b13120414d..4fc137e572 100644
--- a/meta/recipes-devtools/patch/patch_2.7.1.bb
+++ b/meta/recipes-devtools/patch/patch_2.7.1.bb
@@ -10,4 +10,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
acpaths = "-I ${S}/m4 "
-EXTRA_OECONF += "--disable-xattr"
+PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'xattr', 'xattr', '', d)}"
+PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
+