summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-04-27 09:35:28 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-05-05 10:57:35 +0100
commit9ea0f850928b3e7d7a2eb280b8b3ed0c9f977cd6 (patch)
treed01c00ec79ff5205d4f228798754890111c0b476 /meta/recipes-devtools/perl
parent6e317eaab45da2dea70d1485fdae93cfeea0db1d (diff)
downloadopenembedded-core-contrib-9ea0f850928b3e7d7a2eb280b8b3ed0c9f977cd6.tar.gz
perl: patch out build paths from native binaries
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/perl_5.36.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.36.0.bb b/meta/recipes-devtools/perl/perl_5.36.0.bb
index 4d8a919d1e..b8dba00f18 100644
--- a/meta/recipes-devtools/perl/perl_5.36.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.36.0.bb
@@ -109,6 +109,10 @@ do_configure:class-native() {
-Ui_xlocale \
-Alddlflags=' ${LDFLAGS}' \
${PACKAGECONFIG_CONFARGS}
+
+ # This prevents leakage of build paths into perl-native binaries, which
+ # causes non-deterministic troubles when those paths no longer exist or aren't accessible.
+ sed -i -e "s,${STAGING_LIBDIR},/completelyboguspath,g" config.h
}
do_configure:append() {