summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-21 18:14:31 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-22 07:24:44 +0100
commit2706b396ef9699c560cded4384cbfc9d79beaa7f (patch)
tree5dd740db7268be40e5ba24eaca78f3c37705d243 /meta/recipes-devtools/perl
parentf3f60e024a2718d18a68897d7f5ca5e4fbb96f61 (diff)
downloadopenembedded-core-contrib-2706b396ef9699c560cded4384cbfc9d79beaa7f.tar.gz
perl/modules: Add various missing ptest perl module dependencies
Whilst not complete, this resolves some module dependency failures being seen by various lib*-perl ptests and in quilt. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.74.bb2
-rw-r--r--meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb2
-rw-r--r--meta/recipes-devtools/perl/libxml-perl_0.08.bb1
3 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.74.bb b/meta/recipes-devtools/perl/liburi-perl_1.74.bb
index a7cfa0fbe3..fea4d2490e 100644
--- a/meta/recipes-devtools/perl/liburi-perl_1.74.bb
+++ b/meta/recipes-devtools/perl/liburi-perl_1.74.bb
@@ -33,6 +33,6 @@ do_install_prepend() {
rm -rf ${B}/t/file.t
}
-RDEPENDS_${PN}-ptest += "libtest-needs-perl"
+RDEPENDS_${PN}-ptest += "libtest-needs-perl perl-module-test-more"
BBCLASSEXTEND = "native"
diff --git a/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb b/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb
index 95af4d1de6..4cfd28a9da 100644
--- a/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb
+++ b/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb
@@ -50,4 +50,6 @@ do_install_ptest() {
chown -R root:root ${D}${PTEST_PATH}/samples
}
+RDEPENDS_${PN}-ptest += "perl-module-test-more"
+
BBCLASSEXTEND="native nativesdk"
diff --git a/meta/recipes-devtools/perl/libxml-perl_0.08.bb b/meta/recipes-devtools/perl/libxml-perl_0.08.bb
index 0f6099868a..a2eee9aa6e 100644
--- a/meta/recipes-devtools/perl/libxml-perl_0.08.bb
+++ b/meta/recipes-devtools/perl/libxml-perl_0.08.bb
@@ -26,3 +26,4 @@ do_compile() {
cpan_do_compile
}
+RDEPENDS_${PN}-ptest += "libxml-parser-perl"