summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorMingde (Matthew) Zeng <matthew.zeng@windriver.com>2020-02-24 13:10:08 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-28 23:08:11 +0000
commit5198aa954ad0bffb7d6609e5118f642a59595b18 (patch)
tree61e126b95d44486b650a2841fba330e892d0e3f0 /meta/recipes-devtools/perl
parentdb02bd43d84d7ece3ed214a25e114e04c966e6c5 (diff)
downloadopenembedded-core-contrib-5198aa954ad0bffb7d6609e5118f642a59595b18.tar.gz
perl: fix lib/warnings test on core-image-sato
Fixes [YOCTO #13296] The lib/warnings test fails on certain images such as core-image-sato. The upstream has already fixed this issue, thus submitting the relevent backport patch. Signed-off-by: Matthew Zeng <matthew.zeng@windriver.com> -- Mingde (Matthew) Zeng Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/files/0001-PATCH-perl-134117-Close-DATA-in-loc_tools.pl.patch30
-rw-r--r--meta/recipes-devtools/perl/perl_5.30.1.bb2
2 files changed, 31 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/files/0001-PATCH-perl-134117-Close-DATA-in-loc_tools.pl.patch b/meta/recipes-devtools/perl/files/0001-PATCH-perl-134117-Close-DATA-in-loc_tools.pl.patch
new file mode 100644
index 0000000000..79cae0d6fa
--- /dev/null
+++ b/meta/recipes-devtools/perl/files/0001-PATCH-perl-134117-Close-DATA-in-loc_tools.pl.patch
@@ -0,0 +1,30 @@
+From a04a75f20f03aa08ce8118b3b0b3f93eb3e997c5 Mon Sep 17 00:00:00 2001
+From: Richard Leach <rich+perl@hyphen-dash-hyphen.info>
+Date: Sun, 19 May 2019 20:16:41 +0000
+Subject: [PATCH] PATCH: [perl #134117] Close DATA in loc_tools.pl
+
+This prevents unexpected text and fixes test lib/warnings.t
+
+Upstream-Status: Backport [a04a75f20f03aa08ce8118b3b0b3f93eb3e997c5]
+
+Signed-off-by: Matthew Zeng <matthew.zeng@windriver.com>
+
+---
+ t/loc_tools.pl | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/t/loc_tools.pl b/t/loc_tools.pl
+index c76e29388a..beebd98d88 100644
+--- a/t/loc_tools.pl
++++ b/t/loc_tools.pl
+@@ -421,7 +421,7 @@ sub find_locales ($;$) {
+ }
+
+ # The rest of the locales are in this file.
+- push @Data, <DATA>;
++ push @Data, <DATA>; close DATA;
+
+ foreach my $line (@Data) {
+ my ($locale_name, $language_codes, $country_codes, $encodings) =
+--
+2.25.0
diff --git a/meta/recipes-devtools/perl/perl_5.30.1.bb b/meta/recipes-devtools/perl/perl_5.30.1.bb
index 4869012b1a..9d747aa5b4 100644
--- a/meta/recipes-devtools/perl/perl_5.30.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.30.1.bb
@@ -21,6 +21,7 @@ SRC_URI = "https://www.cpan.org/src/5.0/perl-${PV}.tar.gz;name=perl \
file://0001-enc2xs-Add-environment-variable-to-suppress-comments.patch \
file://0002-Constant-Fix-up-shebang.patch \
file://0001-tests-adjust-to-correctly-exclude-unbuilt-extensions.patch \
+ file://0001-PATCH-perl-134117-Close-DATA-in-loc_tools.pl.patch \
file://determinism.patch \
file://racefix.patch \
"
@@ -388,4 +389,3 @@ EOF
chmod 0755 ${SYSROOT_DESTDIR}${bindir}/nativeperl
cat ${SYSROOT_DESTDIR}${bindir}/nativeperl
}
-