summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-03-04 13:58:43 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-06 08:17:26 +0000
commit7f58aed9d7b07d9f86717fc0c45b31b1887eb36a (patch)
tree158f88c13b988352e96061254d42ea8d930b9d35 /meta/recipes-devtools/perl
parent2c0ca4632f6c2ce645412ca975a70b3088c27916 (diff)
downloadopenembedded-core-contrib-7f58aed9d7b07d9f86717fc0c45b31b1887eb36a.tar.gz
libmodule-build-perl: make it reproducible
Particularly, delete html docs as they have sysroot paths in them, and adjust build configuration to not refer to host paths either. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl')
-rw-r--r--meta/recipes-devtools/perl/libmodule-build-perl_0.4231.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/libmodule-build-perl_0.4231.bb b/meta/recipes-devtools/perl/libmodule-build-perl_0.4231.bb
index b1967c7b03..a6fd7b1c07 100644
--- a/meta/recipes-devtools/perl/libmodule-build-perl_0.4231.bb
+++ b/meta/recipes-devtools/perl/libmodule-build-perl_0.4231.bb
@@ -33,13 +33,26 @@ do_patch_module_build () {
do_patch[postfuncs] += "do_patch_module_build"
+EXTRA_CPAN_BUILD_FLAGS = "--create_packlist=0"
+
+do_install_append () {
+ rm -rf ${D}${docdir}/perl/html
+}
+
do_install_ptest() {
cp -r ${B}/inc ${D}${PTEST_PATH}
cp -r ${B}/blib ${D}${PTEST_PATH}
cp -r ${B}/_build ${D}${PTEST_PATH}
cp -r ${B}/lib ${D}${PTEST_PATH}
chown -R root:root ${D}${PTEST_PATH}
- sed -i -e "s,'perl' => .*,'perl' => '/usr/bin/perl'\,,g" ${D}${PTEST_PATH}/_build/build_params
+ sed -i -e "s,'perl' => .*,'perl' => '/usr/bin/perl'\,,g" \
+ -e "s,${STAGING_BINDIR_NATIVE}/perl-native/\.\.,${bindir}/,g" \
+ -e "s,${S},,g" \
+ -e "s,${D},,g" \
+ ${D}${PTEST_PATH}/_build/build_params \
+ ${D}${PTEST_PATH}/_build/runtime_params
+ rm -rf ${D}${PTEST_PATH}/blib/libhtml/site/lib/Module/
+ rm -rf ${D}${PTEST_PATH}/_build/magicnum
}
RDEPENDS_${PN} += " \