summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pkgconf
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2021-11-10 11:12:34 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-10 19:26:15 +0000
commit1ca455a98de4c713f58df0a537d4c982d256cd68 (patch)
treed206f87fe51bf9e7f8ff534579da38d8d26f8440 /meta/recipes-devtools/pkgconf
parent222be29051a3543ac63a0eb07019e90d44429b16 (diff)
downloadopenembedded-core-contrib-1ca455a98de4c713f58df0a537d4c982d256cd68.tar.gz
meta: use ln -rs instead of lnr
lnr is a script in oe-core that creates relative symlinks, with the same behaviour as `ln --relative --symlink`. It was added back in 2014[1] as not all of the supported host distributions at the time shipped coreutils 8.16, the first release with --relative. However the oldest coreutils release in the supported distributions is now 8.22 in CentOS 7, so lnr can be deprecated and users switched to ln. [1] 6ae3b85eaffd1b0b6914422e8de7c1230723157d Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/pkgconf')
-rw-r--r--meta/recipes-devtools/pkgconf/pkgconf_1.8.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/pkgconf/pkgconf_1.8.0.bb b/meta/recipes-devtools/pkgconf/pkgconf_1.8.0.bb
index 29cf4a6a94..887e15e28c 100644
--- a/meta/recipes-devtools/pkgconf/pkgconf_1.8.0.bb
+++ b/meta/recipes-devtools/pkgconf/pkgconf_1.8.0.bb
@@ -59,7 +59,7 @@ pkgconf_sstate_fixup_esdk () {
if [ "${BB_CURRENTTASK}" = "populate_sysroot_setscene" -a "${WITHIN_EXT_SDK}" = "1" ] ; then
pkgconfdir="${SSTATE_INSTDIR}/recipe-sysroot-native/${bindir_native}"
mv $pkgconfdir/pkg-config $pkgconfdir/pkg-config.real
- lnr $pkgconfdir/pkg-config-esdk $pkgconfdir/pkg-config
+ ln -rs $pkgconfdir/pkg-config-esdk $pkgconfdir/pkg-config
sed -i -e "s|^pkg-config|pkg-config.real|" $pkgconfdir/pkg-config-native
fi
}