aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python-backports-lzma/python-backports-lzma_git.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-03-10 13:23:49 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-11 16:08:50 +0000
commite58f876acdac8fff24ecd3076287eda61ef1e4d3 (patch)
tree3b4d45412518185fddabff934242ec5409f7dc9c /meta/recipes-devtools/python-backports-lzma/python-backports-lzma_git.bb
parent6c6f1b318005f4f2e21027b308ab6cb89aefdd19 (diff)
downloadopenembedded-core-contrib-e58f876acdac8fff24ecd3076287eda61ef1e4d3.tar.gz
python-backports-lzma: add a recipe
It is needed by dnf, and only when using Python 2.x, so can be dropped after moving dnf/rpm4 stack to Python 3.x. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python-backports-lzma/python-backports-lzma_git.bb')
-rw-r--r--meta/recipes-devtools/python-backports-lzma/python-backports-lzma_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python-backports-lzma/python-backports-lzma_git.bb b/meta/recipes-devtools/python-backports-lzma/python-backports-lzma_git.bb
new file mode 100644
index 0000000000..6d3b8d569d
--- /dev/null
+++ b/meta/recipes-devtools/python-backports-lzma/python-backports-lzma_git.bb
@@ -0,0 +1,21 @@
+HOMEPAGE = "https://github.com/peterjc/backports.lzma"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=846e05e7e9e1c886b2637c230cfcd5dd"
+
+SRC_URI = "git://github.com/peterjc/backports.lzma.git \
+ file://0001-setup.py-do-not-add-include-and-library-directories-.patch \
+ "
+
+PV = "0.0.6+git${SRCPV}"
+SRCREV = "718b3316ae7aee8e03c02e7e110108779ce3aec8"
+
+S = "${WORKDIR}/git"
+
+inherit distutils
+
+DEPENDS_append = " xz"
+
+RDEPENDS_${PN} += "python-core python-io python-pkgutil"
+RDEPENDS_${PN}_class-native += "python-core"
+
+BBCLASSEXTEND = "native"