aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-nose_1.3.7.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-11-18 16:19:18 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2017-12-11 21:15:37 -0800
commit62c4cbab5a5b45c29aa892160d7aee0066e307c2 (patch)
tree128bb838428ce26df73dd159b70e897b4b518adc /meta/recipes-devtools/python/python-nose_1.3.7.bb
parent7e6b0af5063606561617ac428a90fc85a15fa38c (diff)
downloadopenembedded-core-contrib-62c4cbab5a5b45c29aa892160d7aee0066e307c2.tar.gz
python-nose: use pypi.bbclass
* Simplify python- and python3-nose by using pypi.bbclass * Consolidate common content in python-nose.inc - Avoid duplication by using PYTHON_PN variable Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-nose_1.3.7.bb')
-rw-r--r--meta/recipes-devtools/python/python-nose_1.3.7.bb25
1 files changed, 1 insertions, 24 deletions
diff --git a/meta/recipes-devtools/python/python-nose_1.3.7.bb b/meta/recipes-devtools/python/python-nose_1.3.7.bb
index 9b3509cafb..6d69d2d62e 100644
--- a/meta/recipes-devtools/python/python-nose_1.3.7.bb
+++ b/meta/recipes-devtools/python/python-nose_1.3.7.bb
@@ -1,25 +1,2 @@
-SUMMARY = "Extends Python unittest to make testing easier"
-HOMEPAGE = "http://readthedocs.org/docs/nose/"
-DESCRIPTION = "nose extends the test loading and running features of unittest, \
-making it easier to write, find and run tests."
-SECTION = "devel/python"
-LICENSE = "LGPLv2.1"
-LIC_FILES_CHKSUM = "file://lgpl.txt;md5=a6f89e2100d9b6cdffcea4f398e37343"
-
-SRC_URI = "https://files.pythonhosted.org/packages/source/n/nose/nose-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "4d3ad0ff07b61373d2cefc89c5d0b20b"
-SRC_URI[sha256sum] = "f1bffef9cbc82628f6e7d7b40d7e255aefaa1adb6a1b1d26c69a8b79e6208a98"
-
-UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/nose/"
-UPSTREAM_CHECK_REGEX = "/nose/(?P<pver>(\d+[\.\-_]*)+)"
-
-S = "${WORKDIR}/nose-${PV}"
-
inherit setuptools
-
-RDEPENDS_${PN} = "\
- python-unittest \
- "
-
-BBCLASSEXTEND = "native nativesdk"
+require python-nose.inc