aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-scons_3.0.1.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-11-18 18:28:56 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2017-12-11 21:15:37 -0800
commitce729f8d3911ff2a8ecf85e1f1c7af7fccf5fd33 (patch)
treedc0853a1cfb7a13720dbce83ad0a659a572a0ba3 /meta/recipes-devtools/python/python-scons_3.0.1.bb
parent61912c5ab1684b059bf9bda32d8b0792a704d0e3 (diff)
downloadopenembedded-core-contrib-ce729f8d3911ff2a8ecf85e1f1c7af7fccf5fd33.tar.gz
python-scons: upgrade to v3.0.1; use pypi.bbclasstimo/pypi-v3
* Simplify recipe by using pypi.bbclass * Drop patch for __future__ print_function - fixed upstream: https://github.com/SConsProject/scons/pull/1/commits/4c199d06e76afb9379e76942d0f68caa57f42509 Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-scons_3.0.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-scons_3.0.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-scons_3.0.1.bb b/meta/recipes-devtools/python/python-scons_3.0.1.bb
new file mode 100644
index 0000000000..2f75b08d25
--- /dev/null
+++ b/meta/recipes-devtools/python/python-scons_3.0.1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Software Construction tool (make/autotools replacement)"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=46ddf66004e5be5566367cb525a66fc6"
+
+SRC_URI[md5sum] = "b6a292e251b34b82c203b56cfa3968b3"
+SRC_URI[sha256sum] = "24475e38d39c19683bc88054524df018fe6949d70fbd4c69e298d39a0269f173"
+
+UPSTREAM_CHECK_URI = "http://scons.org/pages/download.html"
+UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} = "\
+ python-fcntl \
+ python-io \
+ python-json \
+ python-subprocess \
+ python-shell \
+ python-pprint \
+ python-importlib \
+ "