summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-importlib-metadata_4.5.0.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@intel.com>2021-06-06 15:34:44 -0700
committerTim Orling <timothy.t.orling@intel.com>2021-06-06 15:34:44 -0700
commitcd8af99664225c78b94acde92345532edd876d74 (patch)
tree4222c0883171bfad455864f44e21910e4058a2df /meta/recipes-devtools/python/python3-importlib-metadata_4.5.0.bb
parent2d919cd7117b000862ac33278b8ba8e4c386b4e0 (diff)
downloadopenembedded-core-contrib-cd8af99664225c78b94acde92345532edd876d74.tar.gz
python3-importlib-metadata: upgrade 4.4.0 -> 4.5.0timo/recipe-upgrades-20210606
Upstream release notes: v4.5.0 Issue 319: Remove SelectableGroups deprecation exception for flake8. Previous upgrade release notes: v4.4.0 Issue 300: Restore compatibility in the result from Distribution.entry_points (EntryPoints) to honor expectations in older implementations and issuing deprecation warnings for these cases: EntryPoints objects are once again mutable, allowing for sort() and other list-based mutation operations. Avoid deprecation warnings by casting to a mutable sequence (e.g. list(dist.entry_points).sort()). EntryPoints results once again allow for access by index. To avoid deprecation warnings, cast the result to a Sequence first (e.g. tuple(dist.entry_points)[0]). v4.3.1 Issue 320: Fix issue where normalized name for eggs was incorrectly solicited, leading to metadata being unavailable for eggs. Signed-off-by: Tim Orling <timothy.t.orling@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3-importlib-metadata_4.5.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-importlib-metadata_4.5.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-importlib-metadata_4.5.0.bb b/meta/recipes-devtools/python/python3-importlib-metadata_4.5.0.bb
new file mode 100644
index 0000000000..7c156787a0
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-importlib-metadata_4.5.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Read metadata from Python packages"
+HOMEPAGE = "https://pypi.org/project/importlib-metadata/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e88ae122f3925d8bde8319060f2ddb8e"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "importlib_metadata"
+UPSTREAM_CHECK_REGEX = "/importlib-metadata/(?P<pver>(\d+[\.\-_]*)+)/"
+
+SRC_URI[sha256sum] = "b142cc1dd1342f31ff04bb7d022492b09920cb64fed867cd3ea6f80fe3ebd139"
+
+S = "${WORKDIR}/importlib_metadata-${PV}"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native ${PYTHON_PN}-toml-native"
+RDEPENDS_${PN} += "${PYTHON_PN}-zipp ${PYTHON_PN}-pathlib2"
+RDEPENDS_${PN}_append_class-target = " python3-misc"
+RDEPENDS_${PN}_append_class-nativesdk = " python3-misc"
+
+BBCLASSEXTEND = "native nativesdk"