aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2014-02-26 09:47:33 -0800
committerSaul Wold <sgw@linux.intel.com>2014-02-28 11:32:11 +0200
commit209a019b12f2941f8aefac9f192e9cdf691196e3 (patch)
treef2b254e28baf6087284fbe92817d6bb8d560a8ee /meta/recipes-devtools/python/python3
parenta88c386239ddc5816d9045d12cf6db4872fa86da (diff)
downloadopenembedded-core-contrib-209a019b12f2941f8aefac9f192e9cdf691196e3.tar.gz
python3: Fix race condition at high parallelism factor
Backport a patch to fix race condition as reported here https://bugzilla.yoctoproject.org/show_bug.cgi?id=5884 [YOCTO #5884] Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python3')
-rw-r--r--meta/recipes-devtools/python/python3/fix-ast.h-dependency.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3/fix-ast.h-dependency.patch b/meta/recipes-devtools/python/python3/fix-ast.h-dependency.patch
new file mode 100644
index 0000000000..77c220aa82
--- /dev/null
+++ b/meta/recipes-devtools/python/python3/fix-ast.h-dependency.patch
@@ -0,0 +1,26 @@
+Fix a missed dependency on ast.h which can result in race condition
+at high parallel build
+
+It fixed here
+
+http://hg.python.org/cpython/rev/cfe0a293551f
+
+[YOCTO #5884]
+
+Upstream-Status: Backport
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: Python-3.3.3/Makefile.pre.in
+===================================================================
+--- Python-3.3.3.orig/Makefile.pre.in 2014-02-26 09:33:13.868288863 -0800
++++ Python-3.3.3/Makefile.pre.in 2014-02-26 09:36:27.348292492 -0800
+@@ -853,7 +853,8 @@
+ $(srcdir)/Include/warnings.h \
+ $(srcdir)/Include/weakrefobject.h \
+ pyconfig.h \
+- $(PARSER_HEADERS)
++ $(PARSER_HEADERS) \
++ $(AST_H)
+
+ $(LIBRARY_OBJS) $(MODOBJS) Modules/python.o: $(PYTHON_HEADERS)
+