summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-11-24 09:32:40 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-26 16:58:55 +0000
commite25d4417bc4ca01474c74dc5bd38594bcfbe6639 (patch)
treeb4d77ee023fc6075e032cd5ddba11113919dec75 /meta/recipes-devtools/python
parent748f7d377b62a0cd6bae558791a4d84b8110ea1a (diff)
downloadopenembedded-core-contrib-e25d4417bc4ca01474c74dc5bd38594bcfbe6639.tar.gz
python: import pyrsistent from meta-python
pyrsistent is a dependency of python3-jsonschema, which is being imported to support kernel device tree validation. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-pyrsistent_0.18.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pyrsistent_0.18.0.bb b/meta/recipes-devtools/python/python3-pyrsistent_0.18.0.bb
new file mode 100644
index 0000000000..0b4d2564f6
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pyrsistent_0.18.0.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Persistent/Immutable/Functional data structures for Python"
+HOMEPAGE = "https://github.com/tobgu/pyrsistent"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.mit;md5=a4b94c2b800b582a8d3925a9939cbf44"
+
+SRC_URI[sha256sum] = "773c781216f8c2900b42a7b638d5b517bb134ae1acbebe4d1e8f1f41ea60eb4b"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-numbers \
+"
+
+BBCLASSEXTEND = "native nativesdk"