aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorJoão Henrique Ferreira de Freitas <joaohf@gmail.com>2014-07-18 00:09:25 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-19 00:08:46 +0100
commit778a00c3dd656bbfac03274b5f60788518f7b964 (patch)
tree589150fd4f4f0c980b3fa82e9270fced90c067f4 /meta/recipes-devtools/python
parentcb70a6128d4886035fba698a8efbc4b91a3706cb (diff)
downloadopenembedded-core-contrib-778a00c3dd656bbfac03274b5f60788518f7b964.tar.gz
python-distribute: add nativesdk to BBCLASSEXTEND
Without this, python tools that need python-distribute doesn't install in SDK generated by OE. Signed-off-by: João Henrique Ferreira de Freitas <joaohf@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python-distribute_0.6.32.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-distribute_0.6.32.bb b/meta/recipes-devtools/python/python-distribute_0.6.32.bb
index 58bb8b4545..70001457e0 100644
--- a/meta/recipes-devtools/python/python-distribute_0.6.32.bb
+++ b/meta/recipes-devtools/python/python-distribute_0.6.32.bb
@@ -39,6 +39,12 @@ do_install_append() {
echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
}
+do_install_append_class-nativesdk() {
+ sed -i -e '1s|^#!.*|#!/usr/bin/env python|' ${D}${PYTHON_SITEPACKAGES_DIR}/distribute-${PV}-py${PYTHON_BASEVERSION}.egg/setuptools/tests/test_resources.py
+ sed -i -e '1s|^#!.*|#!/usr/bin/env python|' ${D}${bindir}/easy_install
+ sed -i -e '1s|^#!.*|#!/usr/bin/env python|' ${D}${bindir}/easy_install-${PYTHON_BASEVERSION}
+}
+
RDEPENDS_${PN} = "\
python-distutils \
python-compression \
@@ -46,4 +52,4 @@ RDEPENDS_${PN} = "\
RPROVIDES_${PN} += "python-setuptools"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"