aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2014-08-13 19:41:04 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-15 18:19:50 +0100
commite16c968ffb96fac3177bb885872c2b5cdde87239 (patch)
treeb50c2cb41e6554a0de6b5a8e526dcf97f0b88621 /meta/recipes-devtools/python
parent4c1f678e4e5383baf40f367e6957dfd33fe52342 (diff)
downloadopenembedded-core-contrib-e16c968ffb96fac3177bb885872c2b5cdde87239.tar.gz
python-scons-native: Make it useable if old host install exists
This was recently fixed to work on Fedora 17 if no scons is installed on the host by setting the PYTHONPATH to where BitBake has installed scons. However, if an older version of scons than 2.3.0 is installed, then it still breaks. This is due to how scons tries to determine its installation by searching through standard paths. If it finds an old installation it prepends that path to sys.path thereby causing it to ignore the PYTHONPATH. The solution is to instead set SCONS_LIB_PATH which works both if scons is not installed and if an older version is installed. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python-scons-native_2.3.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-scons-native_2.3.2.bb b/meta/recipes-devtools/python/python-scons-native_2.3.2.bb
index 067ed61a4e..dae89ab5d2 100644
--- a/meta/recipes-devtools/python/python-scons-native_2.3.2.bb
+++ b/meta/recipes-devtools/python/python-scons-native_2.3.2.bb
@@ -4,5 +4,5 @@ DEPENDS = "python-native"
RDEPENDS_${PN} = ""
do_install_append() {
- create_wrapper ${D}${bindir}/scons PYTHONPATH='$PYTHONPATH:${STAGING_DIR_HOST}/${PYTHON_SITEPACKAGES_DIR}'
+ create_wrapper ${D}${bindir}/scons SCONS_LIB_DIR='${STAGING_DIR_HOST}/${PYTHON_SITEPACKAGES_DIR}'
}