summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/quilt/quilt.inc
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2016-03-25 04:28:54 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-26 22:49:36 +0000
commitf7d52d12f943b9e1f79b32758308607036d6a760 (patch)
treed976e6da4f62465de815d8beea5cde8207aea653 /meta/recipes-devtools/quilt/quilt.inc
parentdbf2ac39913429a0d2a8ce129cebe4469d6a2c22 (diff)
downloadopenembedded-core-contrib-f7d52d12f943b9e1f79b32758308607036d6a760.tar.gz
quilt: run ptest as normal user
When the user is root, run quilt ptest, the faildiff.test failed. Because in the faildiff.test, we drop the read permission of the file test.txt, we can't "quilt refresh" as normal user, so we got the following: >~ .*diff:test\.txt: Permission denied > Diff failed on file 'test.txt', aborting But when the user is root, we can access the file, so we got the following: > Nothing in patch patchs/test.diff So the faildiff.test was failed. We should create a normal user to run the ptest in the run-ptest scripts to slove the problem. Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/quilt/quilt.inc')
-rw-r--r--meta/recipes-devtools/quilt/quilt.inc4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-devtools/quilt/quilt.inc b/meta/recipes-devtools/quilt/quilt.inc
index 837b36ba8c..4e393c4d8f 100644
--- a/meta/recipes-devtools/quilt/quilt.inc
+++ b/meta/recipes-devtools/quilt/quilt.inc
@@ -8,6 +8,7 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/quilt/quilt-${PV}.tar.gz \
file://install.patch \
file://run-ptest \
file://Makefile \
+ file://test.sh \
"
SRC_URI[md5sum] = "fc0310db5868a0873d602d4332a76d43"
@@ -50,8 +51,9 @@ do_install_ptest() {
tar -cf - bin/ --exclude \*.in | ( cd ${D}${PTEST_PATH} && tar -xf - )
tar -cf - compat/ --exclude \*.in | ( cd ${D}${PTEST_PATH} && tar -xf - )
tar -cf - quilt/ --exclude \*.in | ( cd ${D}${PTEST_PATH} && tar -xf - )
- tar -cf - test/ --exclude mail.test --exclude delete.test | ( cd ${D}${PTEST_PATH} && tar -xf - )
+ tar -cf - test/ --exclude mail.test --exclude delete.test | ( cd ${D}${PTEST_PATH} && tar -xf - && chmod 777 test)
cp ${WORKDIR}/Makefile ${D}${PTEST_PATH}
+ cp ${WORKDIR}/test.sh ${D}${PTEST_PATH}
}
RDEPENDS_${PN}-ptest = "make file sed gawk diffutils findutils ed perl \