aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rsync
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-12 15:51:53 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-13 10:12:43 +0100
commit0d9bf9768d0fc19733d9b9120cbd2bbd29b76f25 (patch)
tree3c46452c0fe056e6ff4a76312109c1c29631ff3c /meta/recipes-devtools/rsync
parent2d1948eb325bb769af97634f99efeffe3d43cfc9 (diff)
downloadopenembedded-core-contrib-0d9bf9768d0fc19733d9b9120cbd2bbd29b76f25.tar.gz
rsync: pass cached configure values through the right variable
Passing these through CACHED_CONFIGUREVARS doesn't change the build, but makes the recipe clearer. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rsync')
-rw-r--r--meta/recipes-devtools/rsync/rsync_3.1.2.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/meta/recipes-devtools/rsync/rsync_3.1.2.bb b/meta/recipes-devtools/rsync/rsync_3.1.2.bb
index 5f4733f7b7..4b91ac7774 100644
--- a/meta/recipes-devtools/rsync/rsync_3.1.2.bb
+++ b/meta/recipes-devtools/rsync/rsync_3.1.2.bb
@@ -7,15 +7,14 @@ PACKAGECONFIG ??= "acl attr"
PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
+# By default, if crosscompiling, rsync disables a number of
+# capabilities, hardlinking symlinks and special files (i.e. devices)
+CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
+
# rsync 3.0 uses configure.sh instead of configure, and
# makefile checks the existence of configure.sh
do_configure_prepend () {
rm -f ${S}/configure ${S}/configure.sh
-
- # By default, if crosscompiling, rsync disables a number of
- # capabilities, hardlinking symlinks and special files (i.e. devices)
- export rsync_cv_can_hardlink_special=yes
- export rsync_cv_can_hardlink_symlink=yes
}
do_configure_append () {