summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rust
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2022-12-16 12:06:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-12-17 23:49:04 +0000
commitb187185ceecf1c852b1fdc47451d157a41962d69 (patch)
treed7af6bb23359024bab9f2d6074ddb94708656828 /meta/recipes-devtools/rust
parentf9b0930eab6cf89bbf80c565676c89997b610206 (diff)
downloadopenembedded-core-contrib-b187185ceecf1c852b1fdc47451d157a41962d69.tar.gz
rust: Install target.json for target rustc
As part of the merging builds, installation of target.json was lost causing `rustc` to fail on startup with: error: Error loading target specification: Could not find specification for target "aarch64-poky-linux-gnu". Run `rustc --print target-list` for a list of built-in targets We know the full target specification, so just install it directly rather than using the glob approach from previously. Fixes: b9b0cd99cdc7 ("rust: Enable nativesdk and target builds + replace rust-tools-cross-canadian") Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rust')
-rw-r--r--meta/recipes-devtools/rust/rust_1.65.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rust/rust_1.65.0.bb b/meta/recipes-devtools/rust/rust_1.65.0.bb
index dbf74cec8f..b39f772c5f 100644
--- a/meta/recipes-devtools/rust/rust_1.65.0.bb
+++ b/meta/recipes-devtools/rust/rust_1.65.0.bb
@@ -68,6 +68,9 @@ rust_do_install:class-target() {
chrpath -r "\$ORIGIN/../lib" ${D}${bindir}/$i
done
+ install -d ${D}${libdir}/rustlib/${RUST_HOST_SYS}
+ install -m 0644 ${WORKDIR}/rust-targets/${RUST_HOST_SYS}.json ${D}${libdir}/rustlib/${RUST_HOST_SYS}/target.json
+
chown root:root ${D}/ -R
rm ${D}${libdir}/rustlib/uninstall.sh
rm ${D}${libdir}/rustlib/install.log