summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/syslinux
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-08-05 23:45:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-07 16:08:08 +0100
commitee9afb34fb95409148734fda1eea1fe8f81983fd (patch)
treef95e8377beeffbd67910eb713b86bf59ba0a28e9 /meta/recipes-devtools/syslinux
parentc9559685ebcfb0303fc072c99b3d518427fc5a82 (diff)
downloadopenembedded-core-contrib-ee9afb34fb95409148734fda1eea1fe8f81983fd.tar.gz
syslinux: Override hardcoded toolnames in Makefile
makefile assumes native toolnames e.g. ar, as, nm etc. which causes build fails on non-x86 build hosts objcopy: Unable to recognise the format of the input file `libcom32.elf' Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/syslinux')
-rw-r--r--meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb b/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb
index 67e5d57d48..e9dbefb930 100644
--- a/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb
+++ b/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb
@@ -59,11 +59,26 @@ do_compile() {
# Rebuild only the installer; keep precompiled bootloaders
# as per author's request (doc/distrib.txt)
- oe_runmake CC="${CC} ${CFLAGS}" LD="${LD}" LDFLAGS="${LDFLAGS}" firmware="bios" installer
+ oe_runmake CC="${CC} ${CFLAGS}" \
+ LD="${LD}" LDFLAGS="${LDFLAGS}" \
+ OBJDUMP="${OBJDUMP}" \
+ OBJCOPY="${OBJCOPY}" \
+ AR="${AR}" \
+ STRIP="${STRIP}" \
+ NM="${NM}" \
+ RANLIB="${RANLIB}" \
+ firmware="bios" installer
}
do_install() {
- oe_runmake CC="${CC} ${CFLAGS}" LD="${LD}" firmware="bios" install INSTALLROOT="${D}"
+ oe_runmake CC="${CC} ${CFLAGS}" LD="${LD}" \
+ OBJDUMP="${OBJDUMP}" \
+ OBJCOPY="${OBJCOPY}" \
+ AR="${AR}" \
+ STRIP="${STRIP}" \
+ NM="${NM}" \
+ RANLIB="${RANLIB}" \
+ firmware="bios" install INSTALLROOT="${D}"
install -d ${D}${datadir}/syslinux/
install -m 644 ${S}/bios/core/ldlinux.sys ${D}${datadir}/syslinux/