aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorLeonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com>2016-06-13 17:02:42 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 18:05:22 +0100
commit66aebcc5d59a4eeb3b8229106d02312033b88bef (patch)
tree9d5dd1134bb70a814e3449fb89267fb8481acc67 /meta/recipes-devtools
parent6a275175050085df474be76433ec9c8934b12dad (diff)
downloadopenembedded-core-contrib-66aebcc5d59a4eeb3b8229106d02312033b88bef.tar.gz
flex: Fix top_builddir path for flex's test-driver script
Since 5f82d17ac63f6d5b55f7b8d019c239620ab54596, test-driver scripts look into top_buildir path, so fix this path on flex's tests/Makefile. [YOCTO #9721] (From OE-Core rev: c5da9c7a3c6418386e1f923008e1cd5fbee01fdd) Signed-off-by: Leonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/flex/flex_2.6.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-devtools/flex/flex_2.6.0.bb b/meta/recipes-devtools/flex/flex_2.6.0.bb
index 8285426d45..f6d136c93e 100644
--- a/meta/recipes-devtools/flex/flex_2.6.0.bb
+++ b/meta/recipes-devtools/flex/flex_2.6.0.bb
@@ -51,5 +51,8 @@ do_install_ptest() {
cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
cp -r ${S}/tests/* ${D}${PTEST_PATH}
cp -r ${B}/tests/* ${D}${PTEST_PATH}
- sed -e 's/^Makefile:/_Makefile:/' -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' -i ${D}${PTEST_PATH}/Makefile
+ sed -e 's/^Makefile:/_Makefile:/' \
+ -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \
+ -e 's/^builddir = \(.*\)/builddir = ./' -e 's/^top_builddir = \(.*\)/top_builddir = ./' \
+ -i ${D}${PTEST_PATH}/Makefile
}