aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2016-06-16 16:48:12 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-01 16:22:43 +0100
commit77b572800e8e0f16edd57203054076efc6fed479 (patch)
treef6b86d59444f0b3467d6f3d487c32ef212315d09 /meta/recipes-devtools
parentf4008338c90478642e91e57c805d096037f71478 (diff)
downloadopenembedded-core-contrib-77b572800e8e0f16edd57203054076efc6fed479.tar.gz
systemd: upgrade to 230
Patches are rebased or removed for the latest version. Python testing scripts are removed for systemd-ptest as systemd is configured with '--without-python'. systemd-bootchart is now seprated from systemd, thus removing the related configuration items. And we add systemd-bootchart recipe. [ systemd-bootchart: add missing distro features check - RB ] (From OE-Core rev: 70d782eee573fe46ec512bf59ac6f41e53a99b1b) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/systemd-bootchart/systemd-bootchart_230.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_230.bb b/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_230.bb
new file mode 100644
index 0000000000..9ce629a2b2
--- /dev/null
+++ b/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_230.bb
@@ -0,0 +1,29 @@
+LICENSE = "LGPLv2.1 & GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c \
+ file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe"
+
+SRC_URI = "git://github.com/systemd/systemd-bootchart.git;protocol=https"
+
+# Modify these as desired
+PV = "230+git${SRCPV}"
+SRCREV = "dcb246b46239259ec99b3c6e6ab7d27e1a5a8a84"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "systemd libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native intltool"
+
+inherit pkgconfig autotools systemd distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "systemd"
+
+SYSTEMD_SERVICE_${PN} = "systemd-bootchart.service"
+
+do_configure_prepend() {
+ # intltool.m4 is a soft link to /usr/share/aclocal/m4, delete it and use the one in our sysroot
+ rm -f ${S}/m4/intltool.m4
+}
+
+FILES_${PN} += "${systemd_unitdir}/systemd-bootchart"
+
+EXTRA_OECONF = " --with-rootprefix=${base_prefix} \
+ --with-rootlibdir=${base_libdir}"