summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-01-12 11:23:34 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-13 17:31:46 +0000
commit00254501b9b024032032c9fb068d957de4ef7dde (patch)
treef2fed3563c39d78c1d75eaf3358da43c7ecdb670 /meta/recipes-devtools
parent877c4d5e4cd5ceb71d2ecfdc35a625f50752bec0 (diff)
downloadopenembedded-core-contrib-00254501b9b024032032c9fb068d957de4ef7dde.tar.gz
python3-build: add 0.10.0
This is the PEP517 build frontend blessed by the Python Packaging Authority, and now that Python 3.11 has been released and enough packages have ported to flit, it can be used without a huge bootstraping problem. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3-build_0.10.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-build_0.10.0.bb b/meta/recipes-devtools/python/python3-build_0.10.0.bb
new file mode 100644
index 0000000000..bebc00a437
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-build_0.10.0.bb
@@ -0,0 +1,14 @@
+SUMMARY = "A simple, correct PEP517 package builder"
+HOMEPAGE = "https://github.com/pypa/build"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=310439af287b0fb4780b2ad6907c256c"
+
+SRC_URI[sha256sum] = "d5b71264afdb5951d6704482aac78de887c80691c52b88a9ad195983ca2c9269"
+
+inherit pypi python_flit_core
+
+DEPENDS += "python3-packaging-native python3-pyproject-hooks-native"
+
+RDEPENDS:${PN} += "python3-packaging python3-pyproject-hooks"
+
+BBCLASSEXTEND = "native nativesdk"