summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-03-09 16:19:49 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-11 00:08:38 +0000
commit076815f41740fc480e3fb6b3087840ece1b9e3ce (patch)
tree3af789870bba0cb44a5fe509bc7fcc4f0199eb74 /meta/recipes-devtools
parent6b64ba79c7ff1bd77e8601ff5de1df476f8b2d95 (diff)
downloadopenembedded-core-contrib-076815f41740fc480e3fb6b3087840ece1b9e3ce.tar.gz
make: upgrade 4.4 -> 4.4.1
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/make/make.inc5
-rw-r--r--meta/recipes-devtools/make/make/sigpipe.patch42
-rw-r--r--meta/recipes-devtools/make/make_4.4.1.bb (renamed from meta/recipes-devtools/make/make_4.4.bb)3
3 files changed, 6 insertions, 44 deletions
diff --git a/meta/recipes-devtools/make/make.inc b/meta/recipes-devtools/make/make.inc
index a0a72b6295..56b863480c 100644
--- a/meta/recipes-devtools/make/make.inc
+++ b/meta/recipes-devtools/make/make.inc
@@ -11,3 +11,8 @@ SRC_URI = "${GNU_MIRROR}/make/make-${PV}.tar.gz \
inherit autotools gettext pkgconfig texinfo
PROVIDES = "virtual/make"
+
+# Otherwise $CXX leaks into /usr/bin/make
+do_configure:prepend() {
+ unset CXX
+}
diff --git a/meta/recipes-devtools/make/make/sigpipe.patch b/meta/recipes-devtools/make/make/sigpipe.patch
deleted file mode 100644
index a7270fdbda..0000000000
--- a/meta/recipes-devtools/make/make/sigpipe.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 92ab2e642d2c04b3dcb5a736ae6193680bfd5f74 Mon Sep 17 00:00:00 2001
-From: Paul Smith <psmith@gnu.org>
-Date: Sun, 6 Nov 2022 15:22:02 -0500
-Subject: * src/main.c (main): [SV 63307] Handle SIGPIPE as a fatal signal
-
-Always ignoring SIGPIPE is visible to child processes.
-
-Upstream-Status: Backport [https://git.savannah.gnu.org/cgit/make.git/commit/?id=92ab2e642d2c04b3dcb5a736ae6193680bfd5f74]
-Signed-off-by: Alexander Kanavin <alex@linutronix.de>
----
- src/main.c | 8 +++-----
- 1 file changed, 3 insertions(+), 5 deletions(-)
-
-diff --git a/src/main.c b/src/main.c
-index eec9365..f2caf7a 100644
---- a/src/main.c
-+++ b/src/main.c
-@@ -1182,11 +1182,6 @@ main (int argc, char **argv, char **envp)
- /* Useful for attaching debuggers, etc. */
- SPIN ("main-entry");
-
-- /* Don't die if our stdout sends us SIGPIPE. */
--#ifdef SIGPIPE
-- bsd_signal (SIGPIPE, SIG_IGN);
--#endif
--
- #ifdef HAVE_ATEXIT
- if (ANY_SET (check_io_state (), IO_STDOUT_OK))
- atexit (close_stdout);
-@@ -1265,6 +1260,9 @@ main (int argc, char **argv, char **envp)
- #ifdef SIGQUIT
- FATAL_SIG (SIGQUIT);
- #endif
-+#ifdef SIGPIPE
-+ FATAL_SIG (SIGPIPE);
-+#endif
- FATAL_SIG (SIGINT);
- FATAL_SIG (SIGTERM);
-
---
-cgit v1.1
-
diff --git a/meta/recipes-devtools/make/make_4.4.bb b/meta/recipes-devtools/make/make_4.4.1.bb
index 6642c708d8..c73751ddcb 100644
--- a/meta/recipes-devtools/make/make_4.4.bb
+++ b/meta/recipes-devtools/make/make_4.4.1.bb
@@ -4,11 +4,10 @@ require make.inc
SRC_URI += " \
file://0001-m4-getloadavg.m4-restrict-AIX-specific-test-on-AIX.patch \
- file://sigpipe.patch \
"
EXTRA_OECONF += "--without-guile"
-SRC_URI[sha256sum] = "581f4d4e872da74b3941c874215898a7d35802f03732bdccee1d4a7979105d18"
+SRC_URI[sha256sum] = "dd16fb1d67bfab79a72f5e8390735c49e3e8e70b4945a15ab1f81ddb78658fb3"
BBCLASSEXTEND = "native nativesdk"