summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-03-21 12:37:34 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-21 22:40:45 +0000
commit6d81a8eeb42695c1d908a2ef9d60606c4eb7cf8f (patch)
tree88a3feb3f8894f646d9370986f8bab6bb540bca9 /meta/recipes-devtools
parent66907e95cf1e174c76ee8c495af1596cc1f63718 (diff)
downloadopenembedded-core-contrib-6d81a8eeb42695c1d908a2ef9d60606c4eb7cf8f.tar.gz
python3-bcrypt: use python3-unittest-automake-output
Instead of using sed to reformat the output use this new module. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3-bcrypt/run-ptest2
-rw-r--r--meta/recipes-devtools/python/python3-bcrypt_4.0.1.bb1
2 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-bcrypt/run-ptest b/meta/recipes-devtools/python/python3-bcrypt/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta/recipes-devtools/python/python3-bcrypt/run-ptest
+++ b/meta/recipes-devtools/python/python3-bcrypt/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta/recipes-devtools/python/python3-bcrypt_4.0.1.bb b/meta/recipes-devtools/python/python3-bcrypt_4.0.1.bb
index 6ce45ca6ee..9f5b81330b 100644
--- a/meta/recipes-devtools/python/python3-bcrypt_4.0.1.bb
+++ b/meta/recipes-devtools/python/python3-bcrypt_4.0.1.bb
@@ -17,6 +17,7 @@ require ${BPN}-crates.inc
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-unittest-automake-output \
"
do_install_ptest() {