summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-03-21 12:37:44 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-21 22:40:45 +0000
commit88b320cfb38b69b2d9035d2300359ff3d0dbd598 (patch)
tree12522de109c5bfa992825d98184832c226b63540 /meta/recipes-devtools
parent7da8728e0b566bb326092b88140c2d8207893738 (diff)
downloadopenembedded-core-contrib-88b320cfb38b69b2d9035d2300359ff3d0dbd598.tar.gz
python3-webcolors: use python3-unittest-automake-output
Instead of using sed to reformat the output use this new module. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3-webcolors/run-ptest2
-rw-r--r--meta/recipes-devtools/python/python3-webcolors_1.12.bb1
2 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-webcolors/run-ptest b/meta/recipes-devtools/python/python3-webcolors/run-ptest
index 3385d68939..8d2017d39c 100644
--- a/meta/recipes-devtools/python/python3-webcolors/run-ptest
+++ b/meta/recipes-devtools/python/python3-webcolors/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta/recipes-devtools/python/python3-webcolors_1.12.bb b/meta/recipes-devtools/python/python3-webcolors_1.12.bb
index 39ff19c2b8..02f6c9fed8 100644
--- a/meta/recipes-devtools/python/python3-webcolors_1.12.bb
+++ b/meta/recipes-devtools/python/python3-webcolors_1.12.bb
@@ -17,6 +17,7 @@ SRC_URI += " \
RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-unittest-automake-output \
"
do_install_ptest() {