aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-05 18:49:03 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-08 11:07:58 +0000
commit3b8adee2756085df47b90357eed4c20ee98c7cd1 (patch)
treec4f6858aa37b5aad20cb86803bdc954be4c0875c /meta/recipes-devtools
parent45b7d3add14eafc25da62bab68d4ae133f8dcb57 (diff)
downloadopenembedded-core-contrib-3b8adee2756085df47b90357eed4c20ee98c7cd1.tar.gz
perl: Enable rebuilds to account for configuration changes
If configure/compile was rerun for perl, changes such as libdir changes were not being picked up. To fix this we we add "make clean" functionality, if the makefile is present. We also in this case need to delete the .so file, else some perl modules try and load the target arch libraries leading to build failures. I'd love it if there were a better way to do this and am open to better proposals but this was the best I could find, not being a perl expert. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/perl/perl_5.20.0.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.20.0.bb b/meta/recipes-devtools/perl/perl_5.20.0.bb
index ec01765ea3..ec4d2140e7 100644
--- a/meta/recipes-devtools/perl/perl_5.20.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.20.0.bb
@@ -117,6 +117,16 @@ do_configure() {
# Make hostperl in build directory be the native perl
ln -sf ${HOSTPERL} hostperl
+ if [ -n "${CONFIGURESTAMPFILE}" -a -e "${CONFIGURESTAMPFILE}" ]; then
+ if [ "`cat ${CONFIGURESTAMPFILE}`" != "${BB_TASKHASH}" -a -e Makefile ]; then
+ ${MAKE} clean
+ fi
+ find ${S} -name *.so -delete
+ fi
+ if [ -n "${CONFIGURESTAMPFILE}" ]; then
+ echo ${BB_TASKHASH} > ${CONFIGURESTAMPFILE}
+ fi
+
# Do our work in the cross subdir
cd Cross