summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2020-11-02 10:51:15 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-03 08:20:41 +0000
commit196855101f28aeb8ab44f5ca1e02bfb02a11a256 (patch)
treec6e1b550dc3e08e11076ae2001197e67da3a71d2 /meta/recipes-devtools
parent9923392539b1ce6d70f713527373d6bbc03f3021 (diff)
downloadopenembedded-core-contrib-196855101f28aeb8ab44f5ca1e02bfb02a11a256.tar.gz
rpm: use libgcrypt instead of OpenSSL for cryptography
RPM 4.16 uses libgcrypt by default[1], so change our build to follow. [1] https://github.com/rpm-software-management/rpm/commit/5c0801a1a3cba56d5c7e379323242e26f33f0729 Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.16.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_4.16.0.bb b/meta/recipes-devtools/rpm/rpm_4.16.0.bb
index a578cf3cbd..4125f3f9d0 100644
--- a/meta/recipes-devtools/rpm/rpm_4.16.0.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.16.0.bb
@@ -48,7 +48,7 @@ SRCREV = "cd7f9303ef1070f027493cad7d00bc66935af2a0"
S = "${WORKDIR}/git"
-DEPENDS = "openssl db file popt xz bzip2 elfutils python3"
+DEPENDS = "libgcrypt db file popt xz bzip2 elfutils python3"
DEPENDS_append_class-native = " file-replacement-native bzip2-replacement-native"
inherit autotools gettext pkgconfig python3native
@@ -59,7 +59,7 @@ AUTOTOOLS_AUXDIR = "${S}/build-aux"
# OE-core patches autoreconf to additionally run gnu-configize, which fails with this recipe
EXTRA_AUTORECONF_append = " --exclude=gnu-configize"
-EXTRA_OECONF_append = " --without-lua --enable-python --with-crypto=openssl"
+EXTRA_OECONF_append = " --without-lua --enable-python --with-crypto=libgcrypt"
EXTRA_OECONF_append_libc-musl = " --disable-nls --disable-openmp"
# --sysconfdir prevents rpm from attempting to access machine-specific configuration in sysroot/etc; we need to have it in rootfs