summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorAwais Belal <Awais_Belal@mentor.com>2021-03-30 12:29:21 +0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-04-05 15:27:43 +0100
commit2256afc652d69e720a31f7c5858d5ab32b0065f2 (patch)
tree11bc2831002687b911f1146cae72bf1f0a457153 /meta/recipes-devtools
parent0942515b32d79fd1043adaa27942203680b31cfa (diff)
downloadopenembedded-core-contrib-2256afc652d69e720a31f7c5858d5ab32b0065f2.tar.gz
perl: allow empty lines and comments in perl-rdepends.txt
With this change the rdepends file can now have empty lines and comment lines. The perl-rdepends.txt generation will be fixed with further commits to leverage this change. Signed-off-by: Awais Belal <awais_belal@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/perl/perl_5.32.1.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.32.1.bb b/meta/recipes-devtools/perl/perl_5.32.1.bb
index 1fafc0a8c9..65db6da2b5 100644
--- a/meta/recipes-devtools/perl/perl_5.32.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.32.1.bb
@@ -320,6 +320,9 @@ python split_perl_packages () {
# Read the pre-generated dependency file, and use it to set module dependecies
for line in open(d.expand("${WORKDIR}") + '/perl-rdepends.txt').readlines():
splitline = line.split()
+ # Filter empty lines and comments
+ if len(splitline) == 0 or splitline[0].startswith("#"):
+ continue
if bb.data.inherits_class('native', d):
module = splitline[0] + '-native'
depends = "perl-native"