summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-03-12 13:50:14 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-16 08:48:04 +0000
commit8a34826558b5a0f2a4463f7d7bb230f1473b6621 (patch)
tree9cc678c63b8fbea1aa1373ad98786fe585400611 /meta/recipes-devtools
parent90204d37f303f7f3daddad76b3c86dcf8a1338e7 (diff)
downloadopenembedded-core-contrib-8a34826558b5a0f2a4463f7d7bb230f1473b6621.tar.gz
python3-pycparser: move from meta-python
Dependency for python3-cryptography Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python3-pycparser_2.21.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pycparser_2.21.bb b/meta/recipes-devtools/python/python3-pycparser_2.21.bb
new file mode 100644
index 0000000000..53b7367903
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pycparser_2.21.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Parser of the C language, written in pure Python"
+HOMEPAGE = "https://github.com/eliben/pycparser"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2c28cdeabcb88f5843d934381b4b4fea"
+
+SRC_URI[sha256sum] = "e644fdec12f7872f86c58ff790da456218b10f863970249516d60a5eaca77206"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"
+
+RDEPENDS:${PN}:class-target += "\
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-ply \
+ ${PYTHON_PN}-pprint \
+ "
+
+RSUGGESTS:${PN}:class-target += "\
+ cpp \
+ cpp-symlinks \
+ "