aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bash/bash.inc
diff options
context:
space:
mode:
authorBjörn Stenberg <bjst@enea.com>2013-06-24 09:45:52 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-25 17:43:42 +0100
commitb5fe8c9ff330105337b003be0de2f970545d13ef (patch)
tree749e735b05cfa52c03e7d03610e9a6f43e5e208e /meta/recipes-extended/bash/bash.inc
parentf7409a9fe83ba2535a43f39ed57cd78242a88557 (diff)
downloadopenembedded-core-contrib-b5fe8c9ff330105337b003be0de2f970545d13ef.tar.gz
bash ptest: Sed away the Makefile dependency to remove error messages.
The bash Makefile defines a dependency on itself and tries to run configure, causing error messages when running ptest on target: make: *** No rule to make target `configure.in', needed by `configure'. make: *** No rule to make target `aclocal.m4', needed by `configure'. make: *** No rule to make target `config.h.in', needed by `configure'. make: *** No rule to make target `Makefile.in', needed by `Makefile'. make: Failed to remake makefile `Makefile'. This patch edits out this dependency in the Makefile installed for ptest, to get rid of these messages. Signed-off-by: Sona Sarmadi <sona.sarmadi@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/bash/bash.inc')
-rw-r--r--meta/recipes-extended/bash/bash.inc1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-extended/bash/bash.inc b/meta/recipes-extended/bash/bash.inc
index c619f824e9..2f4519cdda 100644
--- a/meta/recipes-extended/bash/bash.inc
+++ b/meta/recipes-extended/bash/bash.inc
@@ -40,6 +40,7 @@ do_install_append () {
do_install_ptest () {
make INSTALL_TEST_DIR=${D}${PTEST_PATH}/tests install-test
cp ${B}/Makefile ${D}${PTEST_PATH}
+ sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
}
pkg_postinst_${PN} () {