aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cups
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-06-09 19:37:49 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-11 23:59:16 +0100
commitb012fc8b198cea8e6b317e30804c0199ff4d131c (patch)
treec1467d0f17752a6a0c5dfedb51032810d6831b29 /meta/recipes-extended/cups
parent8c9acb766b3ab92224f9b1598eb0196ef6d92974 (diff)
downloadopenembedded-core-contrib-b012fc8b198cea8e6b317e30804c0199ff4d131c.tar.gz
cups: clean up autotools use
Instead of hand-rolling a do_configure() simply use autotools and disable autoheader (upstream uses a hand-generated config.h.in). Also do_compile() doesn't need to pass SSLLIBS as configure uses pkgconfig to find gnutls, LIBPNG and LIBJPEG are not used anywhere in the build system, and LIBZ is detected correctly. (From OE-Core rev: 9c25af5483280c5c753f981504eb373d6e58c7f3) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/cups')
-rw-r--r--meta/recipes-extended/cups/cups.inc14
1 files changed, 2 insertions, 12 deletions
diff --git a/meta/recipes-extended/cups/cups.inc b/meta/recipes-extended/cups/cups.inc
index df47c81d59..ba50296ba7 100644
--- a/meta/recipes-extended/cups/cups.inc
+++ b/meta/recipes-extended/cups/cups.inc
@@ -43,13 +43,7 @@ EXTRA_OECONF = " \
--without-java \
"
-
-do_configure() {
- gnu-configize
- libtoolize --force
- autoconf --force
- DSOFLAGS="${LDFLAGS}" SERVERBIN="${libdir}/cups" oe_runconf
-}
+EXTRA_AUTORECONF += "--exclude=autoheader"
do_compile () {
sed -i s:STRIP:NOSTRIP: Makedefs
@@ -63,11 +57,7 @@ do_compile () {
echo "install-headers:" >> man/Makefile
echo "install-libs:" >> man/Makefile
- oe_runmake "SSLLIBS=-lgnutls -L${STAGING_LIBDIR}" \
- "LIBPNG=-lpng -lm -L${STAGING_LIBDIR}" \
- "LIBJPEG=-ljpeg -L${STAGING_LIBDIR}" \
- "LIBZ=-lz -L${STAGING_LIBDIR}" \
- "-I."
+ oe_runmake
}
do_install () {