aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/gawk/gawk_4.1.4.bb
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-11-04 09:08:38 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-15 15:18:48 +0000
commit7bac3652c2ea0c4d60b1830bc07f2c4c2aaed0ae (patch)
tree025c6ab853b696274c9097c4bdd43189ca98b6df /meta/recipes-extended/gawk/gawk_4.1.4.bb
parentb881a288eec598002685f68da80a24e0478fa496 (diff)
downloadopenembedded-core-contrib-7bac3652c2ea0c4d60b1830bc07f2c4c2aaed0ae.tar.gz
gawk: Update to version 4.1.4
Add patch to remove hashbang line in file test/arrayind1.awk. This patch fixes: / |WARNING: gawk-4.1.4-r0 do_package_qa: QA Issue: |/usr/lib/gawk/ptest/test/arrayind1.awk contained in package gawk-ptest |requires /usr/local/bin/awk, but no providers found in RDEPENDS_gawk-ptest? |[file-rdeps] \ Patch was submitted to upstream [1] [1] https://lists.gnu.org/archive/html/bug-gawk/2016-11/msg00003.html Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/gawk/gawk_4.1.4.bb')
-rw-r--r--meta/recipes-extended/gawk/gawk_4.1.4.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-extended/gawk/gawk_4.1.4.bb b/meta/recipes-extended/gawk/gawk_4.1.4.bb
new file mode 100644
index 0000000000..b888df197c
--- /dev/null
+++ b/meta/recipes-extended/gawk/gawk_4.1.4.bb
@@ -0,0 +1,47 @@
+SUMMARY = "GNU awk text processing utility"
+DESCRIPTION = "The GNU version of awk, a text processing utility. \
+Awk interprets a special-purpose programming language to do \
+quick and easy text pattern matching and reformatting jobs."
+HOMEPAGE = "https://www.gnu.org/software/gawk/"
+BUGTRACKER = "bug-gawk@gnu.org"
+SECTION = "console/utils"
+
+# gawk <= 3.1.5: GPLv2
+# gawk >= 3.1.6: GPLv3
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+DEPENDS += "readline"
+
+PACKAGECONFIG[mpfr] = "--with-mpfr,--without-mpfr, mpfr"
+
+SRC_URI = "${GNU_MIRROR}/gawk/gawk-${PV}.tar.gz \
+ file://run-ptest \
+ file://test-arrayind1-Remove-hashbang-line.patch \
+"
+
+SRC_URI[md5sum] = "f20c94ca51b6ebfc9bffb90f95c8ffbb"
+SRC_URI[sha256sum] = "8c03080e2b5a56263e8783f6f1f306398d4591be18254041f3f547efef944d35"
+
+inherit autotools gettext texinfo update-alternatives
+
+FILES_${PN} += "${datadir}/awk"
+FILES_${PN}-dev += "${libdir}/${BPN}/*.la"
+
+ALTERNATIVE_${PN} = "awk"
+ALTERNATIVE_TARGET[awk] = "${bindir}/gawk"
+ALTERNATIVE_PRIORITY = "100"
+
+do_install_append() {
+ # remove the link since we don't package it
+ rm ${D}${bindir}/awk
+}
+
+inherit ptest
+
+do_install_ptest() {
+ mkdir ${D}${PTEST_PATH}/test
+ for i in `grep -vE "@|^$|#|Gt-dummy" ${S}/test/Maketests |awk -F: '{print $1}'` Maketests; \
+ do cp ${S}/test/$i* ${D}${PTEST_PATH}/test; \
+ done
+}