aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/logrotate
diff options
context:
space:
mode:
authorXiaofeng Yan <xiaofeng.yan@windriver.com>2010-09-01 10:29:03 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-09-02 15:19:34 -0700
commit47423b530f1228fa36f8336687709a87c699114f (patch)
treeb62d78f8bad98b42c770c0656f9e46c36fec6d10 /meta/recipes-extended/logrotate
parentdea8d65f3ce892007bb085d1c283985551d17b10 (diff)
downloadopenembedded-core-contrib-47423b530f1228fa36f8336687709a87c699114f.tar.gz
logrotate: Add new logrotate package
logrotate allows for the rotation, compression and removal of system log file Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
Diffstat (limited to 'meta/recipes-extended/logrotate')
-rw-r--r--meta/recipes-extended/logrotate/logrotate_3.7.9.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-extended/logrotate/logrotate_3.7.9.bb b/meta/recipes-extended/logrotate/logrotate_3.7.9.bb
new file mode 100644
index 0000000000..f657d78871
--- /dev/null
+++ b/meta/recipes-extended/logrotate/logrotate_3.7.9.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Rotates, compresses, removes and mails system log files"
+SECTION = "console/utils"
+PRIORITY = "required"
+HOMEPAGE = "https://fedorahosted.org/releases/l/o/logrotate"
+LICENSE = "GPLv2"
+PR = "r0"
+
+DEPENDS="coreutils"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
+
+SRC_URI = "https://fedorahosted.org/releases/l/o/logrotate/logrotate-${PV}.tar.gz"
+
+
+EXTRA_OEMAKE = "CC='${CC}'"
+
+do_install(){
+ oe_runmake install DESTDIR=${D} PREFIX=${D} MANDIR=${mandir}
+}
+
+do_install_append(){
+ mkdir -p ${D}${sysconfdir}/logrotate.d
+ mkdir -p ${D}${sysconfdir}/cron.daily
+ mkdir -p ${D}${localstatedir}/lib
+ install -p -m 644 examples/logrotate-default ${D}${sysconfdir}/logrotate.conf
+ install -p -m 755 examples/logrotate.cron ${D}${sysconfdir}/cron.daily/logrotate
+ touch ${D}${localstatedir}/lib/logrotate.status
+}