aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsof/lsof_4.87.bb
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2013-01-08 12:09:54 +0200
committerSaul Wold <sgw@linux.intel.com>2013-01-09 16:40:36 -0800
commit24b57b871ab559e8ff5fe5cdd0412ef6ac51f689 (patch)
tree9a11039e726c9e9d19dbafd0ccb6f8c60bf8d474 /meta/recipes-extended/lsof/lsof_4.87.bb
parent1880bcddd2532b22542cc6eccbadf889a1749db9 (diff)
downloadopenembedded-core-contrib-24b57b871ab559e8ff5fe5cdd0412ef6ac51f689.tar.gz
lsof: updated to 4.87
Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/lsof/lsof_4.87.bb')
-rw-r--r--meta/recipes-extended/lsof/lsof_4.87.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-extended/lsof/lsof_4.87.bb b/meta/recipes-extended/lsof/lsof_4.87.bb
new file mode 100644
index 0000000000..2f425aab4a
--- /dev/null
+++ b/meta/recipes-extended/lsof/lsof_4.87.bb
@@ -0,0 +1,54 @@
+SUMMARY = "LiSt Open Files tool"
+DESCRIPTION = "Lsof is a Unix-specific diagnostic tool. \
+Its name stands for LiSt Open Files, and it does just that."
+SECTION = "devel"
+LICENSE = "BSD"
+PR = "r0"
+
+SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "80e2a76d0e05826db910ec88e631296c"
+SRC_URI[sha256sum] = "dfdd3709d82bc79ccdf3e404b84aafa9aede5948642a824ecaefd0aac589da2c"
+
+LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
+S = "${WORKDIR}/lsof_${PV}_src"
+
+LIC_FILES_CHKSUM = "file://${S}/00README;beginline=645;endline=679;md5=964df275d26429ba3b39dbb9f205172a"
+
+python do_unpack () {
+ bb.build.exec_func('base_do_unpack', d)
+ src_uri = d.getVar('SRC_URI')
+ d.setVar('SRC_URI', '${LOCALSRC}')
+ bb.build.exec_func('base_do_unpack', d)
+ d.setVar('SRC_URI', src_uri)
+}
+
+export LSOF_OS = "${TARGET_OS}"
+LSOF_OS_libc-uclibc = "linux"
+LSOF_OS_libc-glibc = "linux"
+export LSOF_INCLUDE = "${STAGING_INCDIR}"
+
+do_configure () {
+ export LSOF_AR="${AR} cr"
+ export LSOF_RANLIB="${RANLIB}"
+ if [ "x${EGLIBCVERSION}" != "x" ];then
+ LINUX_CLIB=`echo ${EGLIBCVERSION} |sed -e 's,\.,,g'`
+ LINUX_CLIB="-DGLIBCV=${LINUX_CLIB}"
+ export LINUX_CLIB
+ fi
+ yes | ./Configure ${LSOF_OS}
+}
+
+export I = "${STAGING_INCDIR}"
+export L = "${STAGING_INCDIR}"
+export EXTRA_OEMAKE = ""
+
+do_compile () {
+ oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}'
+}
+
+do_install () {
+ install -d ${D}${sbindir} ${D}${mandir}/man8
+ install -m 4755 lsof ${D}${sbindir}/lsof
+ install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8
+}