summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2019-03-22 11:57:48 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-25 11:56:52 +0000
commit1e0dbc9e320b200b948abaae418f640f9f65fe06 (patch)
treedf3b86174b42bc002bb6602ecccb3eefa44e34d4 /meta/recipes-extended/mdadm
parente2df6087694af09715141c5cb38af3e7db4ad758 (diff)
downloadopenembedded-core-contrib-1e0dbc9e320b200b948abaae418f640f9f65fe06.tar.gz
mdadm: add -Wno-error to DEBUG_OPTIMIZATION
when compile with DEBUG_OPTIMIZATION(-Og), compile failed with below error, fix by add -Wno-error: [snip] | Incremental.c: In function 'Incremental_container': | Incremental.c:1593:3: error: 'mdfd' may be used uninitialized in this function [-Werror=maybe-uninitialized] | close(mdfd); | ^~~~~~~~~~~ [snip] super-intel.c: In function 'apply_takeover_update': | super-intel.c:9615:15: error: '%d' directive writing between 1 and 11 bytes into a region of size 7 [-Werror=format-overflow=] | " MISSING_%d", du->index); | ^~ ... Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/mdadm')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_4.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_4.1.bb b/meta/recipes-extended/mdadm/mdadm_4.1.bb
index 6b32f08abe..9862a38dc3 100644
--- a/meta/recipes-extended/mdadm/mdadm_4.1.bb
+++ b/meta/recipes-extended/mdadm/mdadm_4.1.bb
@@ -41,6 +41,8 @@ CFLAGS_append_mipsarchn32 = ' -D__SANE_USERSPACE_TYPES__'
EXTRA_OEMAKE = 'CHECK_RUN_DIR=0 CXFLAGS="${CFLAGS}"'
+DEBUG_OPTIMIZATION_append = " -Wno-error"
+
do_compile() {
# Point to right sbindir
sed -i -e "s;BINDIR = /sbin;BINDIR = $base_sbindir;" -e "s;UDEVDIR = /lib;UDEVDIR = $nonarch_base_libdir;" ${S}/Makefile