aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/minicom/minicom_2.5.bb
diff options
context:
space:
mode:
authorShane Wang <shane.wang@intel.com>2011-12-26 23:50:57 +0800
committerSaul Wold <sgw@linux.intel.com>2012-01-02 20:26:24 -0800
commit0585b1c042403e42474e05c634074b63efbcc772 (patch)
tree320f68bb8bc261971bb5db97d66ded1a920e4fff /meta/recipes-extended/minicom/minicom_2.5.bb
parent172a9562aa1df224cf8e60f7d73c4840db96edb5 (diff)
downloadopenembedded-core-contrib-0585b1c042403e42474e05c634074b63efbcc772.tar.gz
minicom: upgrade to 2.5
Signed-off-by: Shane Wang <shane.wang@intel.com>
Diffstat (limited to 'meta/recipes-extended/minicom/minicom_2.5.bb')
-rw-r--r--meta/recipes-extended/minicom/minicom_2.5.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-extended/minicom/minicom_2.5.bb b/meta/recipes-extended/minicom/minicom_2.5.bb
new file mode 100644
index 0000000000..8e93d4d493
--- /dev/null
+++ b/meta/recipes-extended/minicom/minicom_2.5.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Text-based modem control and terminal emulation program"
+DESCRIPTION = "Minicom is a text-based modem control and terminal emulation program for Unix-like operating systems"
+SECTION = "console/network"
+DEPENDS = "ncurses"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=420477abc567404debca0a2a1cb6b645 \
+ file://src/minicom.h;beginline=1;endline=12;md5=a58838cb709f0db517f4e42730c49e81"
+
+SRC_URI = "http://alioth.debian.org/frs/download.php/3487/minicom-${PV}.tar.gz \
+ file://rename-conflicting-functions.patch \
+ "
+# file://gcc4-scope.patch
+
+SRC_URI[md5sum] = "a5117d4d21e2c9e825edb586ee2fe8d2"
+SRC_URI[sha256sum] = "2aa43f98580d3c9c59b12895f15783695cde85472f6bfc7974bcc0935af0a8fd"
+
+inherit autotools gettext
+
+do_install() {
+ for d in doc extras man lib src; do make -C $d DESTDIR=${D} install; done
+}
+