summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
diff options
context:
space:
mode:
authorAmarnath Valluri <amarnath.valluri@intel.com>2017-02-08 11:21:52 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-21 22:43:01 +0000
commit8be0740f8cc8d909a8983b499f200b99261124c4 (patch)
tree48c250b628ccb9a5eb44392c2687b390fd09690f /meta/recipes-extended/net-tools/net-tools_1.60-26.bb
parent3a571f24b183ba0bb0795b9df2b2c9bad331d715 (diff)
downloadopenembedded-core-contrib-8be0740f8cc8d909a8983b499f200b99261124c4.tar.gz
net-tools: Place package content as per bitbake environment.
net-tools Makefile was hardcoded sbin, bin installation paths to /bin and /sbin respectively. This change moves the installed files to appropriate location as per configured bitbake environment. This might be solved much better way by patching Makefile, but that causing build issues, as net-tools recipe is using pre-generated config.{h/status}. Signed-off-by: Amarnath Valluri <amarnath.valluri@intel.com>
Diffstat (limited to 'meta/recipes-extended/net-tools/net-tools_1.60-26.bb')
-rw-r--r--meta/recipes-extended/net-tools/net-tools_1.60-26.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-extended/net-tools/net-tools_1.60-26.bb b/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
index 99a42359b8..be267351e3 100644
--- a/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
+++ b/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
@@ -93,6 +93,17 @@ do_install() {
unset CFLAGS
unset LDFLAGS
oe_runmake 'BASEDIR=${D}' install
+
+ if [ "${base_bindir}" != "/bin" ]; then
+ mkdir -p ${D}/${base_bindir}
+ mv ${D}/bin/* ${D}/${base_bindir}/
+ rmdir ${D}/bin
+ fi
+ if [ "${base_sbindir}" != "/sbin" ]; then
+ mkdir ${D}/${base_sbindir}
+ mv ${D}/sbin/* ${D}/${base_sbindir}/
+ rmdir ${D}/sbin
+ fi
}
inherit update-alternatives