aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/shadow
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-11-09 17:02:43 -0600
committerSaul Wold <sgw@linux.intel.com>2011-11-11 00:33:50 -0800
commit662431ace246e9bb35ad8d0ddd0510193f93517d (patch)
treed94a55cb313d6019b956831710506b45e5bda7d9 /meta/recipes-extended/shadow
parent1ce23fe7d7c33c196af3ba25b4e97496718328d1 (diff)
downloadopenembedded-core-contrib-662431ace246e9bb35ad8d0ddd0510193f93517d.tar.gz
shadow: Generate the shadow files at rootfs construction
With the recent changes to the shadow-native package support "--root", we can now convert the passwd/group files to their shadow forms while doing the rootfs install, instead of waiting to run on the target. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-extended/shadow')
-rw-r--r--meta/recipes-extended/shadow/shadow_4.1.4.3.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/meta/recipes-extended/shadow/shadow_4.1.4.3.bb b/meta/recipes-extended/shadow/shadow_4.1.4.3.bb
index 5bc4a6183e..25330a4cef 100644
--- a/meta/recipes-extended/shadow/shadow_4.1.4.3.bb
+++ b/meta/recipes-extended/shadow/shadow_4.1.4.3.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=08c553a87d4e51bbed50b20e0adcaede \
DEPENDS = "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
RDEPENDS_${PN} = "${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_PLUGINS}', '', d)}"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://pkg-shadow.alioth.debian.org/releases/${BPN}-${PV}.tar.bz2 \
file://login_defs_pam.sed \
@@ -128,11 +128,13 @@ pkg_postinst_${PN} () {
update-alternatives --install ${base_sbindir}/vigr vigr vigr.${PN} 200
if [ "x$D" != "x" ]; then
- exit 1
- fi
+ rootarg="--root=$D"
+ else
+ rootarg=""
+ fi
- pwconv
- grpconv
+ pwconv $rootarg
+ grpconv $rootarg
}
pkg_prerm_${PN} () {