aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2016f.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-07-06 18:35:13 -0700
committerArmin Kuster <akuster808@gmail.com>2016-09-27 08:25:51 -0700
commit455909bcfc9121d9dc722451fae4404007e8399f (patch)
tree8efc8f1786d11d4b69f5947371739dfbdceaf7c3 /meta/recipes-extended/tzcode/tzcode-native_2016f.bb
parentee33dd7f86e172f749646fd4471d24361a2b1e1d (diff)
downloadopenembedded-core-contrib-455909bcfc9121d9dc722451fae4404007e8399f.tar.gz
tzcode-native: update to 2016fakuster/jethro-next
changes done in data (From OE-Core rev: 29377fa91a5f679909d582317c2b53d1f2e5da88) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2016f.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2016f.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2016f.bb b/meta/recipes-extended/tzcode/tzcode-native_2016f.bb
new file mode 100644
index 0000000000..a50a2845d9
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2016f.bb
@@ -0,0 +1,26 @@
+# note that we allow for us to use data later than our code version
+#
+SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
+LICENSE = "PD & BSD & BSD-3-Clause"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=76ae2becfcb9a685041c6f166b44c2c2"
+
+SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
+ http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata"
+
+SRC_URI[tzcode.md5sum] = "b93618bb84e38dee102e0e41ec9d13e2"
+SRC_URI[tzcode.sha256sum] = "72325f384490a310eeb2ea0fab7e6f011a5be19adab2ff9d83bf9d1993b066ed"
+
+SRC_URI[tzdata.md5sum] = "b20b3c1618db1984aac685e763de001d"
+SRC_URI[tzdata.sha256sum] = "ed8c951008d12f1db55a11e96fc055718c6571233327d9de16a7f8475e2502b0"
+
+S = "${WORKDIR}"
+
+inherit native
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 755 zic ${D}${bindir}/
+ install -m 755 zdump ${D}${bindir}/
+ install -m 755 tzselect ${D}${bindir}/
+}