aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorMing Liu <ming.liu@windriver.com>2014-07-03 17:30:01 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-08 11:19:49 +0100
commitc050e5c9490e9e8e07db7fbd5e6c1e1dbef3bf8c (patch)
tree4b7f7326f0d76d165330a36e8d482e4771a6d5c1 /meta/recipes-extended
parentc461454d7f3a20ccf9ca20c5c41c80c9becd985c (diff)
downloadopenembedded-core-contrib-c050e5c9490e9e8e07db7fbd5e6c1e1dbef3bf8c.tar.gz
groff: fix bindir transaction error
bindir is transfered to Makefile as ${D}${bindir}, hence it should not use DESTDIR as the prefix directory any more during the install. Signed-off-by: Ming Liu <ming.liu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/groff/groff-1.18.1.4/groff-1.18.1.4-fix-bindir.patch39
-rw-r--r--meta/recipes-extended/groff/groff_1.18.1.4.bb4
2 files changed, 42 insertions, 1 deletions
diff --git a/meta/recipes-extended/groff/groff-1.18.1.4/groff-1.18.1.4-fix-bindir.patch b/meta/recipes-extended/groff/groff-1.18.1.4/groff-1.18.1.4-fix-bindir.patch
new file mode 100644
index 0000000000..559ae72898
--- /dev/null
+++ b/meta/recipes-extended/groff/groff-1.18.1.4/groff-1.18.1.4-fix-bindir.patch
@@ -0,0 +1,39 @@
+Upstream-Status: Inappropriate [embedded]
+
+Signed-off-by: Ming Liu <ming.liu@windriver.com>
+---
+ Makefile.sub | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+--- a/contrib/groffer/Makefile.sub
++++ b/contrib/groffer/Makefile.sub
+@@ -38,16 +38,16 @@ groffer: groffer.sh groffer2.sh version.
+ $(RM) $@;
+ sed \
+ -e "s|@g@|$(g)|g" \
+- -e "s|@BINDIR@|$(DESTDIR)$(bindir)|g" \
++ -e "s|@BINDIR@|$(bindir)|g" \
+ -e "s|@libdir@|$(DESTDIR)$(libdir)|g" \
+ -e "s|@VERSION@|$(version)$(revision)|g" \
+ $(srcdir)/groffer.sh >$@;
+ chmod +x $@
+
+ install_data: groffer
+- -test -d $(DESTDIR)$(bindir) || $(mkinstalldirs) $(DESTDIR)$(bindir)
+- -$(RM) $(DESTDIR)$(bindir)/groffer
+- $(INSTALL_SCRIPT) groffer $(DESTDIR)$(bindir)/groffer
++ -test -d $(bindir) || $(mkinstalldirs) $(bindir)
++ -$(RM) $(bindir)/groffer
++ $(INSTALL_SCRIPT) groffer $(bindir)/groffer
+ -test -d $(DESTDIR)$(libdir)/groff/groffer || \
+ $(mkinstalldirs) $(DESTDIR)$(libdir)/groff/groffer
+ -$(RM) $(DESTDIR)$(libdir)/groff/groffer/groffer2.sh
+@@ -58,7 +58,7 @@ install_data: groffer
+ $(DESTDIR)$(libdir)/groff/groffer/version.sh
+
+ uninstall_sub:
+- -$(RM) $(DESTDIR)$(bindir)/groffer
++ -$(RM) $(bindir)/groffer
+ -$(RM) $(DESTDIR)$(libdir)/groff/groffer/groffer2.sh
+ -$(RM) $(DESTDIR)$(libdir)/groff/groffer/version.sh
+ -rmdir $(DESTDIR)$(libdir)/groff/groffer
diff --git a/meta/recipes-extended/groff/groff_1.18.1.4.bb b/meta/recipes-extended/groff/groff_1.18.1.4.bb
index 687194909e..38e1d36b83 100644
--- a/meta/recipes-extended/groff/groff_1.18.1.4.bb
+++ b/meta/recipes-extended/groff/groff_1.18.1.4.bb
@@ -11,7 +11,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=e43fc16fccd8519fba405f0a0ff6e8a3"
SRC_URI = "${GNU_MIRROR}/groff/groff-${PV}.tar.gz \
file://groff-1.18.1.4-remove-mom.patch;striplevel=1 \
file://man-local.patch \
- file://mdoc-local.patch"
+ file://mdoc-local.patch \
+ file://groff-1.18.1.4-fix-bindir.patch \
+"
inherit autotools texinfo