aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-25 15:27:52 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-30 15:58:09 +0100
commit4c3738c1496e9f269076861e44a48befebbde39c (patch)
treee0c4c79270772a5b2f7b21a1a955c998789ac65a /meta/recipes-extended
parent239efccccaa74912b3fc9ec717e93f528e2c3836 (diff)
downloadopenembedded-core-contrib-4c3738c1496e9f269076861e44a48befebbde39c.tar.gz
diffutils: Add patch to fix gplv2 version with gcc6
(From OE-Core rev: 9c21339306a5e77ffd256f0a2b1759131109cb64) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/diffutils/diffutils-2.8.1/fix_gcc6.patch31
-rw-r--r--meta/recipes-extended/diffutils/diffutils_2.8.1.bb3
2 files changed, 33 insertions, 1 deletions
diff --git a/meta/recipes-extended/diffutils/diffutils-2.8.1/fix_gcc6.patch b/meta/recipes-extended/diffutils/diffutils-2.8.1/fix_gcc6.patch
new file mode 100644
index 0000000000..f915287fe7
--- /dev/null
+++ b/meta/recipes-extended/diffutils/diffutils-2.8.1/fix_gcc6.patch
@@ -0,0 +1,31 @@
+Fixes to allow diffutils to build with gcc v6.
+
+RP
+2016/5/25
+
+Index: diffutils-2.8.1/lib/posix/regex.h
+===================================================================
+--- diffutils-2.8.1.orig/lib/posix/regex.h
++++ diffutils-2.8.1/lib/posix/regex.h
+@@ -529,7 +529,9 @@ extern int re_exec _RE_ARGS ((const char
+ /* For now unconditionally define __restrict_arr to expand to nothing.
+ Ideally we would have a test for the compiler which allows defining
+ it to restrict. */
++#ifndef __restrict_arr
+ #define __restrict_arr
++#endif
+
+ /* POSIX compatibility. */
+ extern int regcomp _RE_ARGS ((regex_t *__restrict __preg,
+Index: diffutils-2.8.1/src/diff.c
+===================================================================
+--- diffutils-2.8.1.orig/src/diff.c
++++ diffutils-2.8.1/src/diff.c
+@@ -71,6 +71,7 @@ static void usage (void);
+ static bool recursive;
+
+ /* In context diffs, show previous lines that match these regexps. */
++struct re_pattern_buffer function_regexp;
+ static struct regexp_list function_regexp_list;
+
+ /* Ignore changes affecting only lines that match these regexps. */
diff --git a/meta/recipes-extended/diffutils/diffutils_2.8.1.bb b/meta/recipes-extended/diffutils/diffutils_2.8.1.bb
index bf425bbb35..fe56f9ce5f 100644
--- a/meta/recipes-extended/diffutils/diffutils_2.8.1.bb
+++ b/meta/recipes-extended/diffutils/diffutils_2.8.1.bb
@@ -6,7 +6,8 @@ require diffutils.inc
PR = "r7.0"
SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.gz \
- file://diffutils_fix_for_automake-1.12.patch"
+ file://diffutils_fix_for_automake-1.12.patch \
+ file://fix_gcc6.patch"
SRC_URI[md5sum] = "71f9c5ae19b60608f6c7f162da86a428"
SRC_URI[sha256sum] = "c5001748b069224dd98bf1bb9ee877321c7de8b332c8aad5af3e2a7372d23f5a"